summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/ois/ois-1.3-r1.ebuild')
-rw-r--r--dev-games/ois/ois-1.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-games/ois/ois-1.3-r1.ebuild b/dev-games/ois/ois-1.3-r1.ebuild
new file mode 100644
index 000000000000..5b5f0127621b
--- /dev/null
+++ b/dev-games/ois/ois-1.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P=${PN}-v${PV/./-}
+DESCRIPTION="Object-oriented Input System - A cross-platform C++ input handling library"
+HOMEPAGE="https://sourceforge.net/projects/wgois/"
+SRC_URI="mirror://sourceforge/wgois/${MY_P/-/_}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+DEPEND="x11-libs/libXaw
+ x11-libs/libX11"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-automake-1.13.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}