summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/ois/ois-1.3.ebuild')
-rw-r--r--dev-games/ois/ois-1.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-games/ois/ois-1.3.ebuild b/dev-games/ois/ois-1.3.ebuild
new file mode 100644
index 000000000000..c2d80ed398bc
--- /dev/null
+++ b/dev-games/ois/ois-1.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools autotools-utils
+
+MY_P=${PN}-v${PV/./-}
+DESCRIPTION="Object-oriented Input System - A cross-platform C++ input handling library"
+HOMEPAGE="http://sourceforge.net/projects/wgois/"
+SRC_URI="mirror://sourceforge/wgois/${MY_P/-/_}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="static-libs"
+
+DEPEND="x11-libs/libXaw
+ x11-libs/libX11"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-automake-1.13.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ )
+ autotools-utils_src_configure
+
+}