summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/openscenegraph/openscenegraph-3.6.5.ebuild')
-rw-r--r--dev-games/openscenegraph/openscenegraph-3.6.5.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/dev-games/openscenegraph/openscenegraph-3.6.5.ebuild b/dev-games/openscenegraph/openscenegraph-3.6.5.ebuild
index 4614315778aa..6a1d992b139e 100644
--- a/dev-games/openscenegraph/openscenegraph-3.6.5.ebuild
+++ b/dev-games/openscenegraph/openscenegraph-3.6.5.ebuild
@@ -5,7 +5,7 @@ EAPI=7
MY_PN="OpenSceneGraph"
MY_P=${MY_PN}-${PV}
-WX_GTK_VER="3.0"
+WX_GTK_VER="3.0-gtk3"
inherit cmake flag-o-matic wxwidgets
DESCRIPTION="Open source high performance 3D graphics toolkit"
@@ -13,7 +13,7 @@ HOMEPAGE="http://www.openscenegraph.org/"
SRC_URI="https://github.com/${PN}/${MY_PN}/archive/${MY_P}.tar.gz"
LICENSE="wxWinLL-3 LGPL-2.1"
-SLOT="0/160" # NOTE: CHECK WHEN BUMPING! Subslot is SOVERSION
+SLOT="0/161" # NOTE: CHECK WHEN BUMPING! Subslot is SOVERSION
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="asio curl dicom debug doc egl examples ffmpeg fltk fox gdal gif glut
gstreamer jpeg las lua openexr openinventor osgapps pdf png sdl sdl2
@@ -94,9 +94,6 @@ src_configure() {
-DDYNAMIC_OPENSCENEGRAPH=ON
-DLIB_POSTFIX=${libdir/lib}
-DOPENGL_PROFILE=GL2 #GL1 GL2 GL3 GLES1 GLES3 GLES3
- -DOSG_ENVVAR_SUPPORTED=ON
- -DOSG_PROVIDE_READFILE=ON
- -DOSG_USE_LOCAL_LUA_SOURCE=OFF
$(cmake_use_find_package asio Asio)
$(cmake_use_find_package curl CURL)
-DBUILD_DOCUMENTATION=$(usex doc)