summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/openscenegraph')
-rw-r--r--dev-games/openscenegraph/Manifest1
-rw-r--r--dev-games/openscenegraph/files/openscenegraph-3.6.5-cmake_lua_version.patch14
-rw-r--r--dev-games/openscenegraph/files/openscenegraph-3.6.5-openexr3.patch68
-rw-r--r--dev-games/openscenegraph/files/openscenegraph-3.6.5-remove-register-keyword.patch172
-rw-r--r--dev-games/openscenegraph/files/openscenegraph-3.6.5-use_boost_asio.patch55
-rw-r--r--dev-games/openscenegraph/metadata.xml5
-rw-r--r--dev-games/openscenegraph/openscenegraph-3.6.5-r114.ebuild (renamed from dev-games/openscenegraph/openscenegraph-3.6.5-r1.ebuild)75
-rw-r--r--dev-games/openscenegraph/openscenegraph-3.6.5-r115.ebuild (renamed from dev-games/openscenegraph/openscenegraph-3.6.4.ebuild)82
8 files changed, 382 insertions, 90 deletions
diff --git a/dev-games/openscenegraph/Manifest b/dev-games/openscenegraph/Manifest
index 845c83da61a8..b2f78728f975 100644
--- a/dev-games/openscenegraph/Manifest
+++ b/dev-games/openscenegraph/Manifest
@@ -1,2 +1 @@
-DIST OpenSceneGraph-3.6.4.tar.gz 5771539 BLAKE2B 3f608566ed8bd927f30c18ab25147826a40655bfa0eca2b0765f775d1fca53c090b77c9963b392bb73b405150f64f1b3bdc57ac6ef59de7f88bf9fd208b2ff6e SHA512 7cb34fc279ba62a7d7177d3f065f845c28255688bd29026ffb305346e1bb2e515a22144df233e8a7246ed392044ee3e8b74e51bf655282d33ab27dcaf12f4b19
DIST OpenSceneGraph-3.6.5.tar.gz 5780762 BLAKE2B 31ebeeae94eb6aff043788313946d5c08886f97d97cd5796e600918e137ef7f06839206b79b2f5649aac7f34037d4d79e18a5638152e150de931b7f7a7d3c38b SHA512 7002fa30a3bcf6551d2e1050b4ca75a3736013fd190e4f50953717406864da1952deb09f530bc8c5ddf6e4b90204baec7dbc283f497829846d46d561f66feb4b
diff --git a/dev-games/openscenegraph/files/openscenegraph-3.6.5-cmake_lua_version.patch b/dev-games/openscenegraph/files/openscenegraph-3.6.5-cmake_lua_version.patch
new file mode 100644
index 000000000000..1373b296da04
--- /dev/null
+++ b/dev-games/openscenegraph/files/openscenegraph-3.6.5-cmake_lua_version.patch
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -771,10 +771,7 @@
+ FIND_PACKAGE(LIBLAS)
+
+ IF (NOT(OSG_USE_LOCAL_LUA_SOURCE))
+- FIND_PACKAGE(Lua52)
+- IF (NOT (LUA_LIBRARIES AND LUA_INCLUDE_DIR))
+- FIND_PACKAGE(Lua51)
+- ENDIF()
++ FIND_PACKAGE(Lua ${LUA_VERSION} EXACT)
+ ENDIF()
+
+ # V8 and Python plugins are tests for linking against these libraries but aren't functionality beyond this.
diff --git a/dev-games/openscenegraph/files/openscenegraph-3.6.5-openexr3.patch b/dev-games/openscenegraph/files/openscenegraph-3.6.5-openexr3.patch
new file mode 100644
index 000000000000..6a6aa57950d6
--- /dev/null
+++ b/dev-games/openscenegraph/files/openscenegraph-3.6.5-openexr3.patch
@@ -0,0 +1,68 @@
+https://bugs.gentoo.org/833491
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -752,7 +752,6 @@ ELSE()
+- FIND_PACKAGE(ilmbase)
+ FIND_PACKAGE(Inventor)
+ FIND_PACKAGE(Jasper)
+- FIND_PACKAGE(OpenEXR)
++ FIND_PACKAGE(OpenEXR CONFIG)
+ FIND_PACKAGE(OpenCascade)
+ FIND_PACKAGE(COLLADA)
+ FIND_PACKAGE(FBX)
+--- a/src/osgPlugins/CMakeLists.txt
++++ b/src/osgPlugins/CMakeLists.txt
+@@ -105,7 +105,7 @@ ENDIF()
+ IF(JASPER_FOUND)
+ ADD_PLUGIN_DIRECTORY(jp2)
+ ENDIF()
+-IF(OPENEXR_FOUND AND ZLIB_FOUND AND OSG_CPP_EXCEPTIONS_AVAILABLE)
++IF(OpenEXR_FOUND AND ZLIB_FOUND AND OSG_CPP_EXCEPTIONS_AVAILABLE)
+ ADD_PLUGIN_DIRECTORY(exr)
+ ENDIF()
+ IF(GIFLIB_FOUND)
+--- a/src/osgPlugins/exr/CMakeLists.txt
++++ b/src/osgPlugins/exr/CMakeLists.txt
+@@ -1,9 +1,7 @@
+-INCLUDE_DIRECTORIES( ${ILMBASE_INCLUDE_DIR}/OpenEXR )
+-INCLUDE_DIRECTORIES( ${OPENEXR_INCLUDE_DIR}/OpenEXR )
+-
+ SET(TARGET_SRC ReaderWriterEXR.cpp )
+
+-SET(TARGET_LIBRARIES_VARS ${OPENEXR_LIBRARIES_VARS} ${ILMBASE_LIBRARIES_VARS} ZLIB_LIBRARIES)
++SET(OPENEXR_LIBRARIES_VARS OpenEXR::OpenEXR)
++SET(TARGET_LIBRARIES_VARS OPENEXR_LIBRARIES_VARS ZLIB_LIBRARIES)
+
+ IF(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
+ REMOVE_CXX_FLAG(-Wshadow)
+--- a/src/osgPlugins/exr/ReaderWriterEXR.cpp
++++ b/src/osgPlugins/exr/ReaderWriterEXR.cpp
+@@ -41,11 +41,11 @@ public:
+ {
+ return _inStream->read(c,n).good();
+ };
+- virtual Int64 tellg ()
++ virtual uint64_t tellg ()
+ {
+ return _inStream->tellg();
+ };
+- virtual void seekg (Int64 pos)
++ virtual void seekg (uint64_t pos)
+ {
+ _inStream->seekg(pos);
+ };
+@@ -69,11 +69,11 @@ public:
+ {
+ _outStream->write(c,n);
+ };
+- virtual Int64 tellp ()
++ virtual uint64_t tellp ()
+ {
+ return _outStream->tellp();
+ };
+- virtual void seekp (Int64 pos)
++ virtual void seekp (uint64_t pos)
+ {
+ _outStream->seekp(pos);
+ };
diff --git a/dev-games/openscenegraph/files/openscenegraph-3.6.5-remove-register-keyword.patch b/dev-games/openscenegraph/files/openscenegraph-3.6.5-remove-register-keyword.patch
new file mode 100644
index 000000000000..474e738e05c3
--- /dev/null
+++ b/dev-games/openscenegraph/files/openscenegraph-3.6.5-remove-register-keyword.patch
@@ -0,0 +1,172 @@
+diff -ruN osg/src/osgPlugins/cfg/ConfigLexer.cpp my/src/osgPlugins/cfg/ConfigLexer.cpp
+--- osg/src/osgPlugins/cfg/ConfigLexer.cpp 2020-01-31 12:03:07.000000000 +0100
++++ my/src/osgPlugins/cfg/ConfigLexer.cpp 2024-02-24 06:23:01.866597764 +0100
+@@ -832,9 +832,9 @@
+
+ YY_DECL
+ {
+- register yy_state_type yy_current_state;
+- register char *yy_cp, *yy_bp;
+- register int yy_act;
++ yy_state_type yy_current_state;
++ char *yy_cp, *yy_bp;
++ int yy_act;
+
+ #line 35 ".././ConfigLexer.l"
+
+@@ -881,7 +881,7 @@
+ yy_match:
+ do
+ {
+- register YY_CHAR yy_c = yy_ec[YY_SC_TO_UI(*yy_cp)];
++ YY_CHAR yy_c = yy_ec[YY_SC_TO_UI(*yy_cp)];
+ if ( yy_accept[yy_current_state] )
+ {
+ yy_last_accepting_state = yy_current_state;
+@@ -1598,9 +1598,9 @@
+
+ int yyFlexLexer::yy_get_next_buffer()
+ {
+- register char *dest = yy_current_buffer->yy_ch_buf;
+- register char *source = yytext_ptr;
+- register int number_to_move, i;
++ char *dest = yy_current_buffer->yy_ch_buf;
++ char *source = yytext_ptr;
++ int number_to_move, i;
+ int ret_val;
+
+ if ( yy_c_buf_p > &yy_current_buffer->yy_ch_buf[yy_n_chars + 1] )
+@@ -1730,14 +1730,14 @@
+
+ yy_state_type yyFlexLexer::yy_get_previous_state()
+ {
+- register yy_state_type yy_current_state;
+- register char *yy_cp;
++ yy_state_type yy_current_state;
++ char *yy_cp;
+
+ yy_current_state = yy_start;
+
+ for ( yy_cp = yytext_ptr + YY_MORE_ADJ; yy_cp < yy_c_buf_p; ++yy_cp )
+ {
+- register YY_CHAR yy_c = (*yy_cp ? yy_ec[YY_SC_TO_UI(*yy_cp)] : 1);
++ YY_CHAR yy_c = (*yy_cp ? yy_ec[YY_SC_TO_UI(*yy_cp)] : 1);
+ if ( yy_accept[yy_current_state] )
+ {
+ yy_last_accepting_state = yy_current_state;
+@@ -1764,10 +1764,10 @@
+
+ yy_state_type yyFlexLexer::yy_try_NUL_trans( yy_state_type yy_current_state )
+ {
+- register int yy_is_jam;
+- register char *yy_cp = yy_c_buf_p;
++ int yy_is_jam;
++ char *yy_cp = yy_c_buf_p;
+
+- register YY_CHAR yy_c = 1;
++ YY_CHAR yy_c = 1;
+ if ( yy_accept[yy_current_state] )
+ {
+ yy_last_accepting_state = yy_current_state;
+@@ -1786,9 +1786,9 @@
+ }
+
+
+-void yyFlexLexer::yyunput( int c, register char* yy_bp )
++void yyFlexLexer::yyunput( int c, char* yy_bp )
+ {
+- register char *yy_cp = yy_c_buf_p;
++ char *yy_cp = yy_c_buf_p;
+
+ /* undo effects of setting up yytext */
+ *yy_cp = yy_hold_char;
+@@ -1796,10 +1796,10 @@
+ if ( yy_cp < yy_current_buffer->yy_ch_buf + 2 )
+ { /* need to shift things up to make room */
+ /* +2 for EOB chars. */
+- register int number_to_move = yy_n_chars + 2;
+- register char *dest = &yy_current_buffer->yy_ch_buf[
++ int number_to_move = yy_n_chars + 2;
++ char *dest = &yy_current_buffer->yy_ch_buf[
+ yy_current_buffer->yy_buf_size + 2];
+- register char *source =
++ char *source =
+ &yy_current_buffer->yy_ch_buf[number_to_move];
+
+ while ( source > yy_current_buffer->yy_ch_buf )
+@@ -2119,7 +2119,7 @@
+ int n;
+ #endif
+ {
+- register int i;
++ int i;
+ for ( i = 0; i < n; ++i )
+ s1[i] = s2[i];
+ }
+@@ -2133,7 +2133,7 @@
+ yyconst char *s;
+ #endif
+ {
+- register int n;
++ int n;
+ for ( n = 0; s[n]; ++n )
+ ;
+
+diff -ruN osg/src/osgPlugins/cfg/ConfigParser.cpp my/src/osgPlugins/cfg/ConfigParser.cpp
+--- osg/src/osgPlugins/cfg/ConfigParser.cpp 2020-01-31 12:03:07.000000000 +0100
++++ my/src/osgPlugins/cfg/ConfigParser.cpp 2024-02-24 06:21:37.488008033 +0100
+@@ -351,7 +351,7 @@
+ # define YYCOPY(To, From, Count) \
+ do \
+ { \
+- register YYSIZE_T yyi; \
++ YYSIZE_T yyi; \
+ for (yyi = 0; yyi < (Count); yyi++) \
+ (To)[yyi] = (From)[yyi]; \
+ } \
+@@ -1025,7 +1025,7 @@
+ const char *yystr;
+ # endif
+ {
+- register const char *yys = yystr;
++ const char *yys = yystr;
+
+ while (*yys++ != '\0')
+ continue;
+@@ -1050,8 +1050,8 @@
+ const char *yysrc;
+ # endif
+ {
+- register char *yyd = yydest;
+- register const char *yys = yysrc;
++ char *yyd = yydest;
++ const char *yys = yysrc;
+
+ while ((*yyd++ = *yys++) != '\0')
+ continue;
+@@ -1175,8 +1175,8 @@
+ #endif
+ {
+
+- register int yystate;
+- register int yyn;
++ int yystate;
++ int yyn;
+ int yyresult;
+ /* Number of tokens to shift before error messages enabled. */
+ int yyerrstatus;
+@@ -1194,12 +1194,12 @@
+ /* The state stack. */
+ short yyssa[YYINITDEPTH];
+ short *yyss = yyssa;
+- register short *yyssp;
++ short *yyssp;
+
+ /* The semantic value stack. */
+ YYSTYPE yyvsa[YYINITDEPTH];
+ YYSTYPE *yyvs = yyvsa;
+- register YYSTYPE *yyvsp;
++ YYSTYPE *yyvsp;
+
+
+
diff --git a/dev-games/openscenegraph/files/openscenegraph-3.6.5-use_boost_asio.patch b/dev-games/openscenegraph/files/openscenegraph-3.6.5-use_boost_asio.patch
index 4dfeedcaf191..f9a32c0dc601 100644
--- a/dev-games/openscenegraph/files/openscenegraph-3.6.5-use_boost_asio.patch
+++ b/dev-games/openscenegraph/files/openscenegraph-3.6.5-use_boost_asio.patch
@@ -1,6 +1,5 @@
-diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/CMakeLists.txt osg-my/CMakeLists.txt
---- OpenSceneGraph-OpenSceneGraph-3.6.5/CMakeLists.txt 2020-01-31 12:03:07.000000000 +0100
-+++ osg-my/CMakeLists.txt 2020-09-26 18:45:41.191099844 +0200
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
@@ -764,7 +764,7 @@
FIND_PACKAGE(DirectInput)
FIND_PACKAGE(NVTT)
@@ -10,9 +9,8 @@ diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/CMakeLists.txt osg-my/CMakeLists.t
ENDIF()
FIND_PACKAGE(ZeroConf)
-diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/CMakeModules/FindAsio.cmake osg-my/CMakeModules/FindAsio.cmake
---- OpenSceneGraph-OpenSceneGraph-3.6.5/CMakeModules/FindAsio.cmake 2020-01-31 12:03:07.000000000 +0100
-+++ osg-my/CMakeModules/FindAsio.cmake 1970-01-01 01:00:00.000000000 +0100
+--- a/CMakeModules/FindAsio.cmake
++++ b/CMakeModules/FindAsio.cmake
@@ -1,22 +0,0 @@
-# Locate ASIO-headers (http://think-async.com/Asio)
-# This module defines
@@ -36,9 +34,8 @@ diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/CMakeModules/FindAsio.cmake osg-my
- SET(ASIO_FOUND "YES")
- ENDIF()
-ENDIF()
-diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/CMakeLists.txt osg-my/src/osgPlugins/CMakeLists.txt
---- OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/CMakeLists.txt 2020-01-31 12:03:07.000000000 +0100
-+++ osg-my/src/osgPlugins/CMakeLists.txt 2020-09-26 20:04:59.345449848 +0200
+--- a/src/osgPlugins/CMakeLists.txt
++++ b/src/osgPlugins/CMakeLists.txt
@@ -299,13 +299,13 @@
#
# Device integration plugins
@@ -57,9 +54,8 @@ diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/CMakeLists.txt osg-
IF(ZEROCONF_FOUND)
-diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/CMakeLists.txt osg-my/src/osgPlugins/RestHttpDevice/CMakeLists.txt
---- OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/CMakeLists.txt 2020-01-31 12:03:07.000000000 +0100
-+++ osg-my/src/osgPlugins/RestHttpDevice/CMakeLists.txt 2020-09-26 18:46:57.096859301 +0200
+--- a/src/osgPlugins/RestHttpDevice/CMakeLists.txt
++++ b/src/osgPlugins/RestHttpDevice/CMakeLists.txt
@@ -1,6 +1,5 @@
INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
-INCLUDE_DIRECTORIES(${ASIO_INCLUDE_DIR})
@@ -77,9 +73,8 @@ diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/CMak
#### end var setup ###
SETUP_PLUGIN(resthttp)
-diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/connection.cpp osg-my/src/osgPlugins/RestHttpDevice/connection.cpp
---- OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/connection.cpp 2020-01-31 12:03:07.000000000 +0100
-+++ osg-my/src/osgPlugins/RestHttpDevice/connection.cpp 2020-09-26 18:32:19.690576603 +0200
+--- a/src/osgPlugins/RestHttpDevice/connection.cpp
++++ b/src/osgPlugins/RestHttpDevice/connection.cpp
@@ -37,14 +37,14 @@
void connection::start()
{
@@ -112,9 +107,8 @@ diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/conn
socket_.shutdown(asio::ip::tcp::socket::shutdown_both, ignored_ec);
}
-diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/connection.hpp osg-my/src/osgPlugins/RestHttpDevice/connection.hpp
---- OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/connection.hpp 2020-01-31 12:03:07.000000000 +0100
-+++ osg-my/src/osgPlugins/RestHttpDevice/connection.hpp 2020-09-26 19:56:49.410701890 +0200
+--- a/src/osgPlugins/RestHttpDevice/connection.hpp
++++ b/src/osgPlugins/RestHttpDevice/connection.hpp
@@ -11,7 +11,7 @@
#ifndef HTTP_SERVER_CONNECTION_HPP
#define HTTP_SERVER_CONNECTION_HPP
@@ -147,9 +141,8 @@ diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/conn
/// Socket for the connection.
asio::ip::tcp::socket socket_;
-diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/io_service_pool.cpp osg-my/src/osgPlugins/RestHttpDevice/io_service_pool.cpp
---- OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/io_service_pool.cpp 2020-01-31 12:03:07.000000000 +0100
-+++ osg-my/src/osgPlugins/RestHttpDevice/io_service_pool.cpp 2020-09-26 19:56:12.353279737 +0200
+--- a/src/osgPlugins/RestHttpDevice/io_service_pool.cpp
++++ b/src/osgPlugins/RestHttpDevice/io_service_pool.cpp
@@ -11,7 +11,7 @@
#include "server.hpp"
#include <stdexcept>
@@ -181,9 +174,8 @@ diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/io_s
}
void io_service_pool::stop()
-diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/io_service_pool.hpp osg-my/src/osgPlugins/RestHttpDevice/io_service_pool.hpp
---- OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/io_service_pool.hpp 2020-01-31 12:03:07.000000000 +0100
-+++ osg-my/src/osgPlugins/RestHttpDevice/io_service_pool.hpp 2020-09-26 18:37:02.119722575 +0200
+--- a/src/osgPlugins/RestHttpDevice/io_service_pool.hpp
++++ b/src/osgPlugins/RestHttpDevice/io_service_pool.hpp
@@ -11,11 +11,13 @@
#ifndef HTTP_SERVER_IO_SERVICE_POOL_HPP
#define HTTP_SERVER_IO_SERVICE_POOL_HPP
@@ -199,9 +191,8 @@ diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/io_s
namespace http {
namespace server {
-diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/reply.hpp osg-my/src/osgPlugins/RestHttpDevice/reply.hpp
---- OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/reply.hpp 2020-01-31 12:03:07.000000000 +0100
-+++ osg-my/src/osgPlugins/RestHttpDevice/reply.hpp 2020-09-26 18:28:42.741206569 +0200
+--- a/src/osgPlugins/RestHttpDevice/reply.hpp
++++ b/src/osgPlugins/RestHttpDevice/reply.hpp
@@ -13,9 +13,11 @@
#include <string>
@@ -215,9 +206,8 @@ diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/repl
namespace http {
namespace server {
-diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/server.cpp osg-my/src/osgPlugins/RestHttpDevice/server.cpp
---- OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/server.cpp 2020-01-31 12:03:07.000000000 +0100
-+++ osg-my/src/osgPlugins/RestHttpDevice/server.cpp 2020-09-26 19:53:17.692061347 +0200
+--- a/src/osgPlugins/RestHttpDevice/server.cpp
++++ b/src/osgPlugins/RestHttpDevice/server.cpp
@@ -23,7 +23,7 @@
request_handler_(doc_root)
{
@@ -236,9 +226,8 @@ diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/serv
{
if (!e)
{
-diff -ruN OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/server.hpp osg-my/src/osgPlugins/RestHttpDevice/server.hpp
---- OpenSceneGraph-OpenSceneGraph-3.6.5/src/osgPlugins/RestHttpDevice/server.hpp 2020-01-31 12:03:07.000000000 +0100
-+++ osg-my/src/osgPlugins/RestHttpDevice/server.hpp 2020-09-26 18:29:38.894046375 +0200
+--- a/src/osgPlugins/RestHttpDevice/server.hpp
++++ b/src/osgPlugins/RestHttpDevice/server.hpp
@@ -11,7 +11,7 @@
#ifndef HTTP_SERVER_SERVER_HPP
#define HTTP_SERVER_SERVER_HPP
diff --git a/dev-games/openscenegraph/metadata.xml b/dev-games/openscenegraph/metadata.xml
index 9345e47b8272..049f3df3a410 100644
--- a/dev-games/openscenegraph/metadata.xml
+++ b/dev-games/openscenegraph/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>reavertm@gentoo.org</email>
@@ -13,9 +13,8 @@
The OpenSceneGraph is an open source high performance 3D graphics toolkit, used by application developers in fields such as visual simulation, games, virtual reality, scientific visualization and modelling. Written entirely in Standard C++ and OpenGL it runs on all Windows platforms, OSX, GNU/Linux, IRIX, Solaris, HP-Ux, AIX and FreeBSD operating systems. The OpenSceneGraph is now well established as the world leading scene graph technology, used widely in the vis-sim, space, scientific, oil-gas, games and virtual reality industries.
</longdescription>
<use>
- <flag name="asio">Enable support for <pkg>dev-cpp/asio</pkg> library</flag>
+ <flag name="collada">Enable DAE file support via <pkg>dev-libs/collada-dom</pkg></flag>
<flag name="dicom">Enable DICOM medical image file support via <pkg>sci-libs/dcmtk</pkg></flag>
- <flag name="egl">Enable EGL support</flag>
<flag name="fox">Build examples using <pkg>x11-libs/fox</pkg> library</flag>
<flag name="gdal">Enable support for <pkg>sci-libs/gdal</pkg> library</flag>
<flag name="las">Enable support for geospatial data LAS LiDAR format using <pkg>sci-geosciences/liblas</pkg></flag>
diff --git a/dev-games/openscenegraph/openscenegraph-3.6.5-r1.ebuild b/dev-games/openscenegraph/openscenegraph-3.6.5-r114.ebuild
index 66084018cb7c..f1e25ba3592f 100644
--- a/dev-games/openscenegraph/openscenegraph-3.6.5-r1.ebuild
+++ b/dev-games/openscenegraph/openscenegraph-3.6.5-r114.ebuild
@@ -1,38 +1,52 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+LUA_COMPAT=( lua5-1 )
+
+WX_GTK_VER="3.0-gtk3"
+inherit cmake flag-o-matic lua-single wxwidgets
+
MY_PN="OpenSceneGraph"
MY_P=${MY_PN}-${PV}
-WX_GTK_VER="3.0-gtk3"
-inherit cmake flag-o-matic wxwidgets
DESCRIPTION="Open source high performance 3D graphics toolkit"
-HOMEPAGE="http://www.openscenegraph.org/"
+HOMEPAGE="https://www.openscenegraph.com/"
SRC_URI="https://github.com/${PN}/${MY_PN}/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${MY_P}"
LICENSE="wxWinLL-3 LGPL-2.1"
SLOT="0/161" # NOTE: CHECK WHEN BUMPING! Subslot is SOVERSION
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE="curl dicom debug doc egl examples ffmpeg fltk fox gdal gif glut
-gstreamer jpeg las lua openexr openinventor osgapps pdf png sdl sdl2
-svg tiff truetype vnc wxwidgets xrandr +zlib"
+KEYWORDS="amd64 ~arm64 ~hppa ppc64 x86"
+IUSE="
+ collada curl dicom debug doc egl examples ffmpeg fltk fox gdal
+ gif glut gstreamer jpeg las lua openexr openinventor osgapps pdf png
+ sdl sdl2 svg tiff truetype vnc wxwidgets xrandr +zlib
+"
-REQUIRED_USE="sdl2? ( sdl ) dicom? ( zlib ) openexr? ( zlib )"
+REQUIRED_USE="
+ dicom? ( zlib )
+ lua? ( ${LUA_REQUIRED_USE} )
+ openexr? ( zlib )
+ sdl2? ( sdl )
+"
-# TODO: COLLADA, FBX, GTA, NVTT, OpenVRML, Performer
+# TODO: FBX, GTA, NVTT, OpenVRML, Performer
BDEPEND="
app-arch/unzip
virtual/pkgconfig
- doc? ( app-doc/doxygen )
+ doc? ( app-text/doxygen[dot] )
"
+# <ffmpeg-5 for bug #831486 / bug #834425 and
+# https://github.com/openscenegraph/OpenSceneGraph/issues/1111
RDEPEND="
- media-libs/mesa[egl?]
+ media-libs/mesa[egl(+)?]
virtual/glu
virtual/opengl
x11-libs/libSM
x11-libs/libXext
+ collada? ( dev-libs/collada-dom:= )
curl? ( net-misc/curl )
examples? (
fltk? ( x11-libs/fltk:1[opengl] )
@@ -41,19 +55,19 @@ RDEPEND="
sdl2? ( media-libs/libsdl2 )
wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER}[opengl,X] )
)
- ffmpeg? ( media-video/ffmpeg:0= )
+ ffmpeg? ( <media-video/ffmpeg-5:= )
gdal? ( sci-libs/gdal:= )
gif? ( media-libs/giflib:= )
gstreamer? (
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
)
- jpeg? ( virtual/jpeg:0 )
+ jpeg? ( media-libs/libjpeg-turbo:= )
las? ( >=sci-geosciences/liblas-1.8.0 )
- lua? ( >=dev-lang/lua-5.1.5:* )
+ lua? ( ${LUA_DEPS} )
openexr? (
- media-libs/ilmbase:=
- media-libs/openexr:=
+ dev-libs/imath:=
+ >=media-libs/openexr-3:=
)
openinventor? ( media-libs/coin )
pdf? ( app-text/poppler[cairo] )
@@ -63,28 +77,33 @@ RDEPEND="
gnome-base/librsvg
x11-libs/cairo
)
- tiff? ( media-libs/tiff:0 )
+ tiff? ( media-libs/tiff:= )
truetype? ( media-libs/freetype:2 )
vnc? ( net-libs/libvncserver )
xrandr? ( x11-libs/libXrandr )
zlib? ( sys-libs/zlib )
"
DEPEND="${RDEPEND}
- >=dev-libs/boost-1.37.0:*
+ dev-libs/boost
x11-base/xorg-proto
"
-S="${WORKDIR}/${MY_PN}-${MY_P}"
-
PATCHES=(
"${FILESDIR}"/${PN}-3.6.3-cmake.patch
"${FILESDIR}"/${PN}-3.6.3-docdir.patch
"${FILESDIR}"/${PN}-3.6.5-use_boost_asio.patch
+ "${FILESDIR}"/${PN}-3.6.5-cmake_lua_version.patch
+ "${FILESDIR}"/${PN}-3.6.5-openexr3.patch
+ "${FILESDIR}"/${PN}-3.6.5-remove-register-keyword.patch
)
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
src_configure() {
if use examples && use wxwidgets; then
- need-wxwidgets unicode
+ setup-wxwidgets unicode
fi
# Needed by FFmpeg
@@ -95,6 +114,7 @@ src_configure() {
-DDYNAMIC_OPENSCENEGRAPH=ON
-DLIB_POSTFIX=${libdir/lib}
-DOPENGL_PROFILE=GL2 #GL1 GL2 GL3 GLES1 GLES3 GLES3
+ $(cmake_use_find_package collada COLLADA)
$(cmake_use_find_package curl CURL)
-DBUILD_DOCUMENTATION=$(usex doc)
$(cmake_use_find_package dicom DCMTK)
@@ -109,8 +129,7 @@ src_configure() {
$(cmake_use_find_package jpeg JPEG)
-DCMAKE_DISABLE_FIND_PACKAGE_Jasper=ON
$(cmake_use_find_package las LIBLAS)
- $(cmake_use_find_package lua Lua51)
- -DCMAKE_DISABLE_FIND_PACKAGE_Lua52=ON
+ $(cmake_use_find_package lua Lua)
-DCMAKE_DISABLE_FIND_PACKAGE_OpenCascade=ON
$(cmake_use_find_package openexr OpenEXR)
$(cmake_use_find_package openinventor Inventor)
@@ -125,7 +144,9 @@ src_configure() {
$(cmake_use_find_package vnc LibVNCServer)
-DOSGVIEWER_USE_XRANDR=$(usex xrandr)
$(cmake_use_find_package zlib ZLIB)
+ -DOSG_USE_LOCAL_LUA_SOURCE=OFF
)
+
if use examples; then
mycmakeargs+=(
$(cmake_use_find_package fltk FLTK)
@@ -135,6 +156,12 @@ src_configure() {
)
fi
+ if use lua; then
+ mycmakeargs+=(
+ -DLUA_VERSION="$(lua_get_version)"
+ )
+ fi
+
cmake_src_configure
}
diff --git a/dev-games/openscenegraph/openscenegraph-3.6.4.ebuild b/dev-games/openscenegraph/openscenegraph-3.6.5-r115.ebuild
index 14ae3e9ed18a..c9c483e1c962 100644
--- a/dev-games/openscenegraph/openscenegraph-3.6.4.ebuild
+++ b/dev-games/openscenegraph/openscenegraph-3.6.5-r115.ebuild
@@ -1,39 +1,52 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+LUA_COMPAT=( lua5-1 )
+
+WX_GTK_VER="3.2-gtk3"
+inherit cmake flag-o-matic lua-single wxwidgets
+
MY_PN="OpenSceneGraph"
MY_P=${MY_PN}-${PV}
-WX_GTK_VER="3.0-gtk3"
-inherit cmake flag-o-matic wxwidgets
DESCRIPTION="Open source high performance 3D graphics toolkit"
-HOMEPAGE="http://www.openscenegraph.org/"
+HOMEPAGE="https://www.openscenegraph.com/"
SRC_URI="https://github.com/${PN}/${MY_PN}/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${MY_P}"
LICENSE="wxWinLL-3 LGPL-2.1"
-SLOT="0/158" # NOTE: CHECK WHEN BUMPING! Subslot is SOVERSION
-KEYWORDS="amd64 ~hppa ppc ppc64 x86"
-IUSE="asio curl dicom debug doc egl examples ffmpeg fltk fox gdal gif glut
-gstreamer jpeg las lua openexr openinventor osgapps pdf png sdl sdl2
-svg tiff truetype vnc wxwidgets xrandr +zlib"
+SLOT="0/161" # NOTE: CHECK WHEN BUMPING! Subslot is SOVERSION
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc64 ~x86"
+IUSE="
+ collada curl dicom debug doc egl examples ffmpeg fltk fox gdal
+ gif glut gstreamer jpeg las lua openexr openinventor osgapps pdf png
+ sdl sdl2 svg tiff truetype vnc wxwidgets xrandr +zlib
+"
-REQUIRED_USE="sdl2? ( sdl ) dicom? ( zlib ) openexr? ( zlib )"
+REQUIRED_USE="
+ dicom? ( zlib )
+ lua? ( ${LUA_REQUIRED_USE} )
+ openexr? ( zlib )
+ sdl2? ( sdl )
+"
-# TODO: COLLADA, FBX, GTA, NVTT, OpenVRML, Performer
+# TODO: FBX, GTA, NVTT, OpenVRML, Performer
BDEPEND="
app-arch/unzip
virtual/pkgconfig
- doc? ( app-doc/doxygen )
+ doc? ( app-text/doxygen[dot] )
"
+# <ffmpeg-5 for bug #831486 / bug #834425 and
+# https://github.com/openscenegraph/OpenSceneGraph/issues/1111
RDEPEND="
- media-libs/mesa[egl?]
+ media-libs/mesa[egl(+)?]
virtual/glu
virtual/opengl
x11-libs/libSM
x11-libs/libXext
- asio? ( dev-cpp/asio )
+ collada? ( dev-libs/collada-dom:= )
curl? ( net-misc/curl )
examples? (
fltk? ( x11-libs/fltk:1[opengl] )
@@ -42,19 +55,19 @@ RDEPEND="
sdl2? ( media-libs/libsdl2 )
wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER}[opengl,X] )
)
- ffmpeg? ( media-video/ffmpeg:0= )
+ ffmpeg? ( <media-video/ffmpeg-5:= )
gdal? ( sci-libs/gdal:= )
gif? ( media-libs/giflib:= )
gstreamer? (
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
)
- jpeg? ( virtual/jpeg:0 )
+ jpeg? ( media-libs/libjpeg-turbo:= )
las? ( >=sci-geosciences/liblas-1.8.0 )
- lua? ( >=dev-lang/lua-5.1.5:* )
+ lua? ( ${LUA_DEPS} )
openexr? (
- media-libs/ilmbase:=
- media-libs/openexr:=
+ dev-libs/imath:=
+ >=media-libs/openexr-3:=
)
openinventor? ( media-libs/coin )
pdf? ( app-text/poppler[cairo] )
@@ -64,26 +77,33 @@ RDEPEND="
gnome-base/librsvg
x11-libs/cairo
)
- tiff? ( media-libs/tiff:0 )
+ tiff? ( media-libs/tiff:= )
truetype? ( media-libs/freetype:2 )
vnc? ( net-libs/libvncserver )
xrandr? ( x11-libs/libXrandr )
zlib? ( sys-libs/zlib )
"
DEPEND="${RDEPEND}
+ dev-libs/boost
x11-base/xorg-proto
"
-S="${WORKDIR}/${MY_PN}-${MY_P}"
-
PATCHES=(
"${FILESDIR}"/${PN}-3.6.3-cmake.patch
"${FILESDIR}"/${PN}-3.6.3-docdir.patch
+ "${FILESDIR}"/${PN}-3.6.5-use_boost_asio.patch
+ "${FILESDIR}"/${PN}-3.6.5-cmake_lua_version.patch
+ "${FILESDIR}"/${PN}-3.6.5-openexr3.patch
+ "${FILESDIR}"/${PN}-3.6.5-remove-register-keyword.patch
)
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
src_configure() {
if use examples && use wxwidgets; then
- need-wxwidgets unicode
+ setup-wxwidgets unicode
fi
# Needed by FFmpeg
@@ -94,10 +114,7 @@ src_configure() {
-DDYNAMIC_OPENSCENEGRAPH=ON
-DLIB_POSTFIX=${libdir/lib}
-DOPENGL_PROFILE=GL2 #GL1 GL2 GL3 GLES1 GLES3 GLES3
- -DOSG_ENVVAR_SUPPORTED=ON
- -DOSG_PROVIDE_READFILE=ON
- -DOSG_USE_LOCAL_LUA_SOURCE=OFF
- $(cmake_use_find_package asio Asio)
+ $(cmake_use_find_package collada COLLADA)
$(cmake_use_find_package curl CURL)
-DBUILD_DOCUMENTATION=$(usex doc)
$(cmake_use_find_package dicom DCMTK)
@@ -112,8 +129,7 @@ src_configure() {
$(cmake_use_find_package jpeg JPEG)
-DCMAKE_DISABLE_FIND_PACKAGE_Jasper=ON
$(cmake_use_find_package las LIBLAS)
- $(cmake_use_find_package lua Lua51)
- -DCMAKE_DISABLE_FIND_PACKAGE_Lua52=ON
+ $(cmake_use_find_package lua Lua)
-DCMAKE_DISABLE_FIND_PACKAGE_OpenCascade=ON
$(cmake_use_find_package openexr OpenEXR)
$(cmake_use_find_package openinventor Inventor)
@@ -128,7 +144,9 @@ src_configure() {
$(cmake_use_find_package vnc LibVNCServer)
-DOSGVIEWER_USE_XRANDR=$(usex xrandr)
$(cmake_use_find_package zlib ZLIB)
+ -DOSG_USE_LOCAL_LUA_SOURCE=OFF
)
+
if use examples; then
mycmakeargs+=(
$(cmake_use_find_package fltk FLTK)
@@ -138,6 +156,12 @@ src_configure() {
)
fi
+ if use lua; then
+ mycmakeargs+=(
+ -DLUA_VERSION="$(lua_get_version)"
+ )
+ fi
+
cmake_src_configure
}