summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/wfmath/files/wfmath-1.0.2-fix-bashisms.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-games/wfmath/files/wfmath-1.0.2-fix-bashisms.patch b/dev-games/wfmath/files/wfmath-1.0.2-fix-bashisms.patch
new file mode 100644
index 000000000000..d9a6edcfbd95
--- /dev/null
+++ b/dev-games/wfmath/files/wfmath-1.0.2-fix-bashisms.patch
@@ -0,0 +1,16 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -81,11 +81,11 @@ PKG_CHECK_MODULES(ATLAS_0_6, atlascpp-0.6 >= 0.6.0,
+ dnl those should already be using Atlas explicitly.
+ ], found_atlas_0_6=no)
+
+-AM_CONDITIONAL(HAVE_ATLAS_0_6, test $found_atlas_0_6 == yes)
++AM_CONDITIONAL(HAVE_ATLAS_0_6, test $found_atlas_0_6 = xyes)
+
+ AC_CHECK_HEADERS(sstream strstream, [ found_string_stream=yes break ],
+ [ found_string_stream=no ])
+-if test $found_string_stream == no ; then
++if test $found_string_stream = xno ; then
+ AC_MSG_ERROR(Couldn't find C++ string <-> stream conversion method.)
+ fi
+