summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/glide/glide-0.13.1.ebuild')
-rw-r--r--dev-go/glide/glide-0.13.1.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-go/glide/glide-0.13.1.ebuild b/dev-go/glide/glide-0.13.1.ebuild
deleted file mode 100644
index ea72460755a3..000000000000
--- a/dev-go/glide/glide-0.13.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/Masterminds/glide"
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="Vendor Package Managment for Golang"
-HOMEPAGE="https://github.com/Masterminds/glide"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE=""
-
-RESTRICT="test"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-src_compile() {
- GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" go build -ldflags="-X main.version=${PV}" -o "bin/glide" glide.go || die
-}
-
-src_install() {
- dodoc README.md CHANGELOG.md
- dobin bin/glide
-}