summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-protobuf/Manifest1
-rw-r--r--dev-go/go-protobuf/go-protobuf-0_pre20150809.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-go/go-protobuf/Manifest b/dev-go/go-protobuf/Manifest
index 38d6184f0c43..79b0ac253f56 100644
--- a/dev-go/go-protobuf/Manifest
+++ b/dev-go/go-protobuf/Manifest
@@ -1 +1,2 @@
DIST go-protobuf-0_pre20150727.tar.gz 151982 SHA256 160ad98eb1477492476ba566d218262fe6d326410d5a030c6a00433eaf7f9006 SHA512 04802b8d74ccaa17f9fc030badd0e74b6e47233ca5f1faab7c49f25bef2f06efd97aa4bf3f4783a7815958354744ddb9fee96d183aebbb03864069b0cc569564 WHIRLPOOL f49157a4a1a48c67b72ed38121ba28aec3f9b3405a3388097caba36643715c14b6915f9bcbd04f974fa98e9f2c4c4a4e313480ef307701c0ace734e9c214c010
+DIST go-protobuf-0_pre20150809.tar.gz 151982 SHA256 160ad98eb1477492476ba566d218262fe6d326410d5a030c6a00433eaf7f9006 SHA512 04802b8d74ccaa17f9fc030badd0e74b6e47233ca5f1faab7c49f25bef2f06efd97aa4bf3f4783a7815958354744ddb9fee96d183aebbb03864069b0cc569564 WHIRLPOOL f49157a4a1a48c67b72ed38121ba28aec3f9b3405a3388097caba36643715c14b6915f9bcbd04f974fa98e9f2c4c4a4e313480ef307701c0ace734e9c214c010
diff --git a/dev-go/go-protobuf/go-protobuf-0_pre20150809.ebuild b/dev-go/go-protobuf/go-protobuf-0_pre20150809.ebuild
new file mode 100644
index 000000000000..a1fbf95e1edf
--- /dev/null
+++ b/dev-go/go-protobuf/go-protobuf-0_pre20150809.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_SRC=github.com/golang/protobuf
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="68c687dc49948540b356a6b47931c9be4fcd0245"
+ SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go support for Google's protocol buffers"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+ dobin bin/*
+}