summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/alex/alex-3.2.1.ebuild')
-rw-r--r--dev-haskell/alex/alex-3.2.1.ebuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/dev-haskell/alex/alex-3.2.1.ebuild b/dev-haskell/alex/alex-3.2.1.ebuild
deleted file mode 100644
index 4301b5a3c4ff..000000000000
--- a/dev-haskell/alex/alex-3.2.1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ebuild generated by hackport 0.5.9999
-#hackport: flags: +small_base
-
-CABAL_FEATURES="test-suite"
-inherit autotools haskell-cabal
-
-DESCRIPTION="Alex is a tool for generating lexical analysers in Haskell"
-HOMEPAGE="https://www.haskell.org/alex/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND=">=dev-haskell/quickcheck-2:2=
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- doc? ( ~app-text/docbook-xml-dtd-4.2
- app-text/docbook-xsl-stylesheets
- >=dev-libs/libxslt-1.1.2 )
-"
-
-RESTRICT=test # fails tests
-
-src_prepare() {
- default
-
- # drop depend on itself and happy, otherwise cabal tries to regenerate it
- rm src/{Scan.x,Parser.y} || die
-
- for f in Scan Parser; do
- mv "${S}/dist/build/alex/alex-tmp/$f.hs" "${S}"/src/ || die
- done
-
- if use doc; then
- cd "${S}/doc/"
- eautoreconf
- fi
-}
-
-src_configure() {
- # make sure we don't accidentally use those
- # installed in system
- haskell-cabal_src_configure \
- --with-alex=false \
- --with-happy=false \
- --flag=small_base
-
- if use doc; then
- cd "${S}/doc/"
- econf
- fi
-}
-
-src_compile() {
- haskell-cabal_src_compile
-
- if use doc; then
- emake -C "${S}/doc/" -j1
- fi
-}
-
-src_test() {
- # workaround https://github.com/haskell/cabal/issues/2398
- emake -k -C tests all
-}
-
-src_install() {
- haskell-cabal_src_install
-
- if use doc; then
- doman "${S}/doc/alex.1"
- dohtml -r "${S}/doc/alex/"
- fi
-}