summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/binary-orphans/binary-orphans-0.1.6.0-r1.ebuild')
-rw-r--r--dev-haskell/binary-orphans/binary-orphans-0.1.6.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/binary-orphans/binary-orphans-0.1.6.0-r1.ebuild b/dev-haskell/binary-orphans/binary-orphans-0.1.6.0-r1.ebuild
new file mode 100644
index 000000000000..d47e578a5ab3
--- /dev/null
+++ b/dev-haskell/binary-orphans/binary-orphans-0.1.6.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Orphan instances for binary"
+HOMEPAGE="https://github.com/phadej/binary-orphans#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.7.0.6:=[profile?] <dev-haskell/aeson-1.2:=[profile?]
+ >=dev-haskell/case-insensitive-1.2.0.4:=[profile?] <dev-haskell/case-insensitive-1.2.1:=[profile?]
+ >=dev-haskell/hashable-1.2.3.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-haskell/nats-1:=[profile?] <dev-haskell/nats-1.2:=[profile?]
+ >=dev-haskell/scientific-0.3.3.8:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.16.2.2:=[profile?]
+ >=dev-haskell/tagged-0.7.3:=[profile?] <dev-haskell/tagged-0.8.6:=[profile?]
+ >=dev-haskell/text-1.2.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/text-binary-0.1.0:=[profile?] <dev-haskell/text-binary-0.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.5.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.10.12.3:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-haskell/vector-binary-instances-0.2.1.0:=[profile?] <dev-haskell/vector-binary-instances-0.3:=[profile?]
+ >=dev-haskell/void-0.7:=[profile?] <dev-haskell/void-0.8:=[profile?]
+ >=dev-lang/ghc-7.6.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/quickcheck-2.7 <dev-haskell/quickcheck-2.9.3
+ >=dev-haskell/quickcheck-instances-0.3.11 <dev-haskell/quickcheck-instances-0.3.13
+ >=dev-haskell/tasty-0.10.1.2 <dev-haskell/tasty-0.12
+ >=dev-haskell/tasty-quickcheck-0.8.3.2 <dev-haskell/tasty-quickcheck-0.9 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'semigroups >=0.16.2.2 && <0.18.3' 'semigroups >=0.16.2.2'
+}