summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/biocore')
-rw-r--r--dev-haskell/biocore/biocore-0.3.1.ebuild8
-rw-r--r--dev-haskell/biocore/files/biocore-0.3.1-ghc84.patch28
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-haskell/biocore/biocore-0.3.1.ebuild b/dev-haskell/biocore/biocore-0.3.1.ebuild
index a03f1244d73a..54d16dfe8cd0 100644
--- a/dev-haskell/biocore/biocore-0.3.1.ebuild
+++ b/dev-haskell/biocore/biocore-0.3.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
# ebuild generated by hackport 0.3.3.9999
@@ -9,7 +9,7 @@ CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="A bioinformatics library"
-HOMEPAGE="https://hackage.haskell.org/package/biocore"
+HOMEPAGE="http://hackage.haskell.org/package/biocore"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="LGPL-2.1"
@@ -23,3 +23,7 @@ RDEPEND="dev-haskell/stringable:=[profile?]
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6.0.3
"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ghc84.patch
+)
diff --git a/dev-haskell/biocore/files/biocore-0.3.1-ghc84.patch b/dev-haskell/biocore/files/biocore-0.3.1-ghc84.patch
new file mode 100644
index 000000000000..b0a404eb8b46
--- /dev/null
+++ b/dev-haskell/biocore/files/biocore-0.3.1-ghc84.patch
@@ -0,0 +1,28 @@
+--- a/src/Bio/Core/Sequence.hs
++++ b/src/Bio/Core/Sequence.hs
+@@ -37,2 +37,3 @@ import Data.Stringable hiding (length)
+ import Data.Monoid
++import qualified Data.Semigroup as S
+
+@@ -42,2 +43,5 @@ newtype SeqData = SeqData { unSD :: LC.ByteString }
+
++instance S.Semigroup SeqData where
++ (<>) (SeqData s1) (SeqData s2) = SeqData (mappend s1 s2)
++
+ instance Monoid SeqData where
+@@ -51,2 +55,9 @@ newtype SeqLabel = SeqLabel { unSL :: LC.ByteString }
+
++instance S.Semigroup SeqLabel where
++ (<>) (SeqLabel s1) (SeqLabel s2) = let
++ (i1:r1) = LC.words s1
++ (i2:r2) = LC.words s2
++ sid = mconcat [i1,(LC.pack ":"),i2]
++ in SeqLabel (LC.unwords ([sid]++r1++[LC.pack ":"]++r2))
++
+ instance Monoid SeqLabel where
+@@ -68,2 +79,5 @@ newtype QualData = QualData { unQD :: L.ByteString }
+
++instance S.Semigroup QualData where
++ (<>) (QualData s1) (QualData s2) = QualData (mappend s1 s2)
++
+ instance Monoid QualData where