summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/doctest-driver-gen/doctest-driver-gen-0.3.0.7.ebuild')
-rw-r--r--dev-haskell/doctest-driver-gen/doctest-driver-gen-0.3.0.7.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-haskell/doctest-driver-gen/doctest-driver-gen-0.3.0.7.ebuild b/dev-haskell/doctest-driver-gen/doctest-driver-gen-0.3.0.7.ebuild
new file mode 100644
index 000000000000..eca005fa90d4
--- /dev/null
+++ b/dev-haskell/doctest-driver-gen/doctest-driver-gen-0.3.0.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generate driver file for doctest's cabal integration"
+HOMEPAGE="https://github.com/Hexirp/doctest-driver-gen#readme"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="executable"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.0.7-add-executable-flag.patch"
+)
+
+CABAL_TEST_REQUIRED_BINS=(
+ "${PN}"
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ dev-haskell/doctest
+ )
+"
+
+src_configure() {
+ if use executable || use test; then
+ local exe_flag=--flag=executable
+ else
+ local exe_flag=--flag=-executable
+ fi
+
+ # test-suite preprocessor needs the newly built components
+ export LD_LIBRARY_PATH="${S}/dist/build/${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
+ export PATH="${S}/dist/build/${PN}${PATH+:}${PATH}"
+
+ haskell-cabal_src_configure "${exe_flag}"
+}
+
+src_install() {
+ local components=( "lib:${PN}" )
+ use executable && components+=( "exe:${PN}" )
+ haskell-cabal_src_install "${components[@]}"
+}