summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/gtk/gtk-0.14.10-r3.ebuild')
-rw-r--r--dev-haskell/gtk/gtk-0.14.10-r3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/gtk/gtk-0.14.10-r3.ebuild b/dev-haskell/gtk/gtk-0.14.10-r3.ebuild
new file mode 100644
index 000000000000..bfb99727150d
--- /dev/null
+++ b/dev-haskell/gtk/gtk-0.14.10-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.5.9999
+#hackport: flags: have-gio:gio,-have-quartz-gtk
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Gtk+ graphical user interface library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+deprecated +fmode-binary +gio"
+
+RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
+ >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pango-0.13.0.0:=[profile?] <dev-haskell/pango-0.14:=[profile?]
+ >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ gio? ( >=dev-haskell/gio-0.13.0:=[profile?] <dev-haskell/gio-0.14:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24 <dev-haskell/cabal-3.3
+ >=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
+ virtual/pkgconfig
+"
+
+PATCHES=("${FILESDIR}"/${PN}-0.14.10-glib-2.62.patch)
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'Cabal >= 1.24 && < 2.3' 'Cabal >= 1.24 && < 3.3'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag deprecated deprecated) \
+ $(cabal_flag fmode-binary fmode-binary) \
+ $(cabal_flag gio have-gio) \
+ --flag=-have-quartz-gtk
+}