summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild')
-rw-r--r--dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild b/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
index 6f71fc5a2a92..8d237bf11d1c 100644
--- a/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
+++ b/dev-haskell/hdbc-sqlite3/hdbc-sqlite3-2.3.3.1-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-# ebuild generated by hackport 0.5.1
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: -buildtests
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
@@ -17,28 +18,23 @@ SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="buildtests +splitbase"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+splitbase"
RDEPEND=">=dev-db/sqlite-3.0
- >=dev-haskell/hdbc-2.3.0.0:2=[profile?]
+ >=dev-haskell/hdbc-2.3.0.0:=[profile?]
dev-haskell/mtl:=[profile?]
dev-haskell/utf8-string:=[profile?]
>=dev-lang/ghc-7.4.1:=
- buildtests? ( dev-haskell/convertible:=[profile?]
- dev-haskell/hunit:=[profile?]
- dev-haskell/old-locale:=[profile?]
- dev-haskell/old-time:=[profile?]
- dev-haskell/testpack:=[profile?] )
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.2.3
+ >=dev-haskell/cabal-1.2
"
S="${WORKDIR}/${MY_P}"
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag buildtests buildtests) \
+ --flag=-buildtests \
$(cabal_flag splitbase splitbase)
}