summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/language-c/language-c-0.8.3.ebuild')
-rw-r--r--dev-haskell/language-c/language-c-0.8.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/language-c/language-c-0.8.3.ebuild b/dev-haskell/language-c/language-c-0.8.3.ebuild
new file mode 100644
index 000000000000..9fa1ef71fc32
--- /dev/null
+++ b/dev-haskell/language-c/language-c-0.8.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: -allwarnings,+separatesyb,+usebytestrings,+splitbase,+iecfpextension
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Analysis and generation of C code"
+HOMEPAGE="http://visq.github.io/language-c/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/syb:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.22.2.0
+ dev-haskell/happy
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-allwarnings \
+ --flag=iecfpextension \
+ --flag=separatesyb \
+ --flag=splitbase \
+ --flag=usebytestrings
+}