summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/language-dot/language-dot-0.1.1.ebuild')
-rw-r--r--dev-haskell/language-dot/language-dot-0.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/language-dot/language-dot-0.1.1.ebuild b/dev-haskell/language-dot/language-dot-0.1.1.ebuild
new file mode 100644
index 000000000000..cdd922c51593
--- /dev/null
+++ b/dev-haskell/language-dot/language-dot-0.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A library for the analysis and creation of Graphviz DOT files"
+HOMEPAGE="http://hackage.haskell.org/package/language-dot"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+executable"
+
+RDEPEND=">=dev-haskell/parsec-3:=[profile?] <dev-haskell/parsec-4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ >=dev-haskell/mtl-1:=[profile?] <dev-haskell/mtl-3:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}