summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/lukko/lukko-0.1.1.2.ebuild')
-rw-r--r--dev-haskell/lukko/lukko-0.1.1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/lukko/lukko-0.1.1.2.ebuild b/dev-haskell/lukko/lukko-0.1.1.2.ebuild
new file mode 100644
index 000000000000..dc9393ce2aea
--- /dev/null
+++ b/dev-haskell/lukko/lukko-0.1.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="File locking"
+HOMEPAGE="http://hackage.haskell.org/package/lukko"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ofd-locking"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2
+ test? ( >=dev-haskell/async-2.2.2 <dev-haskell/async-2.3
+ >=dev-haskell/singleton-bool-0.1.5 <dev-haskell/singleton-bool-0.2
+ >=dev-haskell/tagged-0.8.5 <dev-haskell/tagged-0.9
+ >=dev-haskell/tasty-1.2.3 <dev-haskell/tasty-1.3
+ >=dev-haskell/tasty-expected-failure-0.11.1.2 <dev-haskell/tasty-expected-failure-0.12
+ >=dev-haskell/tasty-hunit-0.10.0.2 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/temporary-1.3 <dev-haskell/temporary-1.4 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag ofd-locking ofd-locking)
+}