summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/mysql/mysql-0.1.7.ebuild')
-rw-r--r--dev-haskell/mysql/mysql-0.1.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/mysql/mysql-0.1.7.ebuild b/dev-haskell/mysql/mysql-0.1.7.ebuild
new file mode 100644
index 000000000000..430ba9a0ad8a
--- /dev/null
+++ b/dev-haskell/mysql/mysql-0.1.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A low-level MySQL client library"
+HOMEPAGE="https://github.com/paul-rouse/mysql"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # needs local mysql
+
+RDEPEND=">=dev-haskell/semigroups-0.11:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hspec )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}