summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/optparse-simple/optparse-simple-0.1.1.2.ebuild')
-rw-r--r--dev-haskell/optparse-simple/optparse-simple-0.1.1.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/optparse-simple/optparse-simple-0.1.1.2.ebuild b/dev-haskell/optparse-simple/optparse-simple-0.1.1.2.ebuild
new file mode 100644
index 000000000000..55010cdd03e5
--- /dev/null
+++ b/dev-haskell/optparse-simple/optparse-simple-0.1.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Simple interface to optparse-applicative"
+HOMEPAGE="https://github.com/fpco/optparse-simple#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="build-example"
+
+RDEPEND=">=dev-haskell/githash-0.1.3.0:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ >=dev-lang/ghc-8.0.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.2.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag build-example build-example)
+}