summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.2.2.ebuild')
-rw-r--r--dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.2.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.2.2.ebuild b/dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.2.2.ebuild
new file mode 100644
index 000000000000..d240a29a02ac
--- /dev/null
+++ b/dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Use pandoc types in Lua"
+HOMEPAGE="https://github.com/pandoc/pandoc-lua-marshal"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/aeson-1.5:=[profile?] <dev-haskell/aeson-2.2:=[profile?]
+ >=dev-haskell/hslua-2.2:=[profile?] <dev-haskell/hslua-2.4:=[profile?]
+ >=dev-haskell/hslua-list-1.1:=[profile?] <dev-haskell/hslua-list-1.2:=[profile?]
+ >=dev-haskell/hslua-marshalling-2.2:=[profile?] <dev-haskell/hslua-marshalling-2.4:=[profile?]
+ >=dev-haskell/lua-2.2:=[profile?] <dev-haskell/lua-2.4:=[profile?]
+ >=dev-haskell/pandoc-types-1.23:=[profile?] <dev-haskell/pandoc-types-1.24:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+ >=dev-haskell/text-1.1.1.0:=[profile?] <dev-haskell/text-2.1:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-lua-1.0
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11 )
+"