summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/sha/sha-1.6.4.2.ebuild')
-rw-r--r--dev-haskell/sha/sha-1.6.4.2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-haskell/sha/sha-1.6.4.2.ebuild b/dev-haskell/sha/sha-1.6.4.2.ebuild
index c1c37c05ab7f..e796c590c23c 100644
--- a/dev-haskell/sha/sha-1.6.4.2.ebuild
+++ b/dev-haskell/sha/sha-1.6.4.2.ebuild
@@ -19,9 +19,11 @@ SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
+KEYWORDS="amd64 x86 ~amd64-linux"
IUSE="exe"
+RESTRICT=test # fails to build on ghc-7.6, https://ghc.haskell.org/trac/ghc/ticket/8657
+
RDEPEND=">=dev-haskell/binary-0.7:=[profile?] <dev-haskell/binary-10000:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
@@ -34,6 +36,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ cabal_chdeps \
+ ' -O2' ' '
+}
+
src_configure() {
haskell-cabal_src_configure \
--flag=decoderinterface \