summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/skylighting-core/skylighting-core-0.14.ebuild')
-rw-r--r--dev-haskell/skylighting-core/skylighting-core-0.14.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/skylighting-core/skylighting-core-0.14.ebuild b/dev-haskell/skylighting-core/skylighting-core-0.14.ebuild
new file mode 100644
index 000000000000..b0dddfad41b1
--- /dev/null
+++ b/dev-haskell/skylighting-core/skylighting-core-0.14.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +system-pcre
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="syntax highlighting library"
+HOMEPAGE="https://github.com/jgm/skylighting"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ >=dev-haskell/colour-2.0:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-haskell/xml-conduit-1.9.1.3:=[profile?] <dev-haskell/xml-conduit-1.10:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( dev-haskell/diff
+ dev-haskell/pretty-show
+ dev-haskell/quickcheck
+ dev-haskell/tasty
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ --flag=system-pcre
+}