summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/streaming-commons')
-rw-r--r--dev-haskell/streaming-commons/Manifest5
-rw-r--r--dev-haskell/streaming-commons/metadata.xml11
-rw-r--r--dev-haskell/streaming-commons/streaming-commons-0.1.10.0.ebuild41
-rw-r--r--dev-haskell/streaming-commons/streaming-commons-0.1.12.1.ebuild43
-rw-r--r--dev-haskell/streaming-commons/streaming-commons-0.1.3.ebuild38
-rw-r--r--dev-haskell/streaming-commons/streaming-commons-0.1.7.3.ebuild35
-rw-r--r--dev-haskell/streaming-commons/streaming-commons-0.1.8.ebuild35
7 files changed, 208 insertions, 0 deletions
diff --git a/dev-haskell/streaming-commons/Manifest b/dev-haskell/streaming-commons/Manifest
new file mode 100644
index 000000000000..04f8ad8821bf
--- /dev/null
+++ b/dev-haskell/streaming-commons/Manifest
@@ -0,0 +1,5 @@
+DIST streaming-commons-0.1.10.0.tar.gz 84940 SHA256 187187e7788c85c9492612a7534cc13ef877034b5abea9315b27f721f3957a95 SHA512 698339a745ef3d7109ba845848522ca67dced5437db58eae7455d0073f070acc75ce4cf3112c4ffa4b5453619d1be26e1b2aeecc6c09f6ce669b981f1346f4ca WHIRLPOOL abdf78c7f66af25cae7fd94597636e6f2e876ef5990f346b80062b03173b330ccfad0f309e7231d9f5d3515d14944fd50aecb6afe720a83c29aab9b58786982c
+DIST streaming-commons-0.1.12.1.tar.gz 86864 SHA256 d5bd8dd0b11a13d1d128d15dce31b3f2f4625c7f72d4420e749d85bf170a4fd7 SHA512 43f30a7cacdcec178885cb424a7fd0380682482130ba4019d116468bb87bb187244ff480fc169a27de8192e17c9f17fe38396df1b83827f5dd578112765aa64e WHIRLPOOL 9b9a42682195175cdf0ace602c8bb0ddcec372498ce3126dd74a8435e07d5a78c3b3c04325c03cbdf31ea4414da821a999f0948f43e59cb322663145524d8b1a
+DIST streaming-commons-0.1.3.tar.gz 75947 SHA256 0366bdbf4da59cf823f34a31cce93992771fc9fc6096deeb7aabec8a6902637f SHA512 bc08e52564cdc07163113105c61ce03828ad10b40ff10fcc12cc7181054cff7853bbb2e1aef543bbd8972ea2aad9ff293fddb238251d13114e2287f39682bf2b WHIRLPOOL 8d91fca02611b46a952b98456b154373154c84b2a18bb17512abf0368bb10ad36d653dbc5a46c0d203d12cb26d2f3cfb4647fea1e94a83164ff4111ade39b22b
+DIST streaming-commons-0.1.7.3.tar.gz 79209 SHA256 ab7f9e481f0809c34dad20c791862ab558cdba8808a11284a7cf67095b2a558b SHA512 f41de7e9a4e3b3aca909be2ee6a8404b0aba5da1058700354d43d984c9a32da85a677b4a4ddfc7a3a32c90672b142165a4b5b254a5558af1cace502ab2c1e077 WHIRLPOOL eaf3cea0dfed6aec7239120063d68ba32c9c39391537cfa32e26d6e860f5cd408bf2e3748fb025db7c1fcae281cb930390c6f8a90fd4ecf1a7c198960894def0
+DIST streaming-commons-0.1.8.tar.gz 79258 SHA256 0f969599694ba4c168871dda1c70f7067e1a520344fb4ce1bd09a923a70d43e6 SHA512 5644cfc745ec4b0520fd2413f4c1334e814fe10a34e0767982b7fb34d66213b35f33ad826110036a9021dad2eb8d0ade4785b9c2a88b72b128048984e15256e9 WHIRLPOOL 7c15db31edb674ecf2e35ffa186a3448a9fdf0783db6f2a5496b12e5c05e50fee402839c315e907d225a2e5434437c0e3927fdacd6b0a08fa72f5230b37860c8
diff --git a/dev-haskell/streaming-commons/metadata.xml b/dev-haskell/streaming-commons/metadata.xml
new file mode 100644
index 000000000000..b5fe9cc26185
--- /dev/null
+++ b/dev-haskell/streaming-commons/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Provides low-dependency functionality commonly needed by various streaming data libraries, such as conduit and pipes.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">fpco/streaming-commons</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/streaming-commons/streaming-commons-0.1.10.0.ebuild b/dev-haskell/streaming-commons/streaming-commons-0.1.10.0.ebuild
new file mode 100644
index 000000000000..c53ec4275ffd
--- /dev/null
+++ b/dev-haskell/streaming-commons/streaming-commons-0.1.10.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+#hackport: flags: -use-bytestring-builder
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Common lower-level functions needed by various streaming data libraries"
+HOMEPAGE="https://github.com/fpco/streaming-commons"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/blaze-builder-0.3:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ dev-haskell/network:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/async
+ >=dev-haskell/hspec-1.8
+ dev-haskell/quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-use-bytestring-builder
+}
diff --git a/dev-haskell/streaming-commons/streaming-commons-0.1.12.1.ebuild b/dev-haskell/streaming-commons/streaming-commons-0.1.12.1.ebuild
new file mode 100644
index 000000000000..d846aedcc53a
--- /dev/null
+++ b/dev-haskell/streaming-commons/streaming-commons-0.1.12.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: -use-bytestring-builder
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Common lower-level functions needed by various streaming data libraries"
+HOMEPAGE="https://github.com/fpco/streaming-commons"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # slow/hung?
+
+RDEPEND=">=dev-haskell/blaze-builder-0.3:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ dev-haskell/network:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/async
+ >=dev-haskell/hspec-1.8
+ dev-haskell/quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-use-bytestring-builder
+}
diff --git a/dev-haskell/streaming-commons/streaming-commons-0.1.3.ebuild b/dev-haskell/streaming-commons/streaming-commons-0.1.3.ebuild
new file mode 100644
index 000000000000..91e31aa0683d
--- /dev/null
+++ b/dev-haskell/streaming-commons/streaming-commons-0.1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Common lower-level functions needed by various streaming data libraries"
+HOMEPAGE="https://github.com/fpco/streaming-commons"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/blaze-builder-0.3:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
+ dev-haskell/network:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/async
+ dev-haskell/blaze-builder
+ >=dev-haskell/hspec-1.8
+ dev-haskell/network
+ dev-haskell/quickcheck
+ dev-haskell/text
+ dev-haskell/zlib )
+"
diff --git a/dev-haskell/streaming-commons/streaming-commons-0.1.7.3.ebuild b/dev-haskell/streaming-commons/streaming-commons-0.1.7.3.ebuild
new file mode 100644
index 000000000000..b08524bd6859
--- /dev/null
+++ b/dev-haskell/streaming-commons/streaming-commons-0.1.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Common lower-level functions needed by various streaming data libraries"
+HOMEPAGE="https://github.com/fpco/streaming-commons"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/blaze-builder-0.3:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
+ dev-haskell/network:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/async
+ >=dev-haskell/hspec-1.8
+ dev-haskell/quickcheck )
+"
diff --git a/dev-haskell/streaming-commons/streaming-commons-0.1.8.ebuild b/dev-haskell/streaming-commons/streaming-commons-0.1.8.ebuild
new file mode 100644
index 000000000000..b08524bd6859
--- /dev/null
+++ b/dev-haskell/streaming-commons/streaming-commons-0.1.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Common lower-level functions needed by various streaming data libraries"
+HOMEPAGE="https://github.com/fpco/streaming-commons"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/blaze-builder-0.3:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
+ dev-haskell/network:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/async
+ >=dev-haskell/hspec-1.8
+ dev-haskell/quickcheck )
+"