summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/tasty-golden')
-rw-r--r--dev-haskell/tasty-golden/Manifest3
-rw-r--r--dev-haskell/tasty-golden/files/tasty-golden-2.2.1-haddock.patch11
-rw-r--r--dev-haskell/tasty-golden/metadata.xml14
-rw-r--r--dev-haskell/tasty-golden/tasty-golden-2.2.2.3.ebuild33
-rw-r--r--dev-haskell/tasty-golden/tasty-golden-2.2.2.4.ebuild32
-rw-r--r--dev-haskell/tasty-golden/tasty-golden-2.3.0.1.ebuild32
6 files changed, 125 insertions, 0 deletions
diff --git a/dev-haskell/tasty-golden/Manifest b/dev-haskell/tasty-golden/Manifest
new file mode 100644
index 000000000000..cdeee80f3289
--- /dev/null
+++ b/dev-haskell/tasty-golden/Manifest
@@ -0,0 +1,3 @@
+DIST tasty-golden-2.2.2.3.tar.gz 6925 SHA256 5ca0186aae5b09bcb60dc393b57674cae442c104a923b8fb280ff485498df06e SHA512 34cc40a217d8bb34a2263a1eace31f49590698968aacc795e21dfed24a666388bf9536eb5a360e7b4e1a2228324470e9193e27f1cea0863e5ac13ba5ae7e673f WHIRLPOOL ebe9c9b6fc2f4753c0f64fda24a85fd5c3dbba76d5fdfe3caba7b18ea51f7f0cf064f50cb950afeb623468fefa350ea431ebc15a8808036cbe7fde22c9994615
+DIST tasty-golden-2.2.2.4.tar.gz 7102 SHA256 2cd0ac55b3edd218cf713842681aafa036db2aaf24558b303f9f64030624cc24 SHA512 7674f0003595a9569ecf05c7b68608887f815361c9c7b234cba3a0af4eda855a1131fbafcfb15cff19c584dd4f9888e3cc001deea8ac110c648d66a9fe1c7237 WHIRLPOOL b58a160bbd626128bbff5fe9d807a82703e15c563c19037d6e7546c7bc855429c91f25c6d40ad86903e36c983a31d12892ddfe3342df5a810a03c42d9cb3da70
+DIST tasty-golden-2.3.0.1.tar.gz 7098 SHA256 5146fc0121435d64ecb75c73ac71aad46a1159a1d169eeecd91adefc607754a6 SHA512 2488c47f05c4ba038ca054495a378ecb57c7e989de3dc81de85ce7ab673448ac7b436e9078a0be84ed8a98c5aa64ffd08998fe38a5bd947d425fb5bed8b5bf8d WHIRLPOOL 8868c3fc9d286005e4c4131dcd17e99eb766dff44308f3cea03917e8a67ebfb4d4a22cb632bc727974fd24f08a621409a940791d2247ff7c3c0aebed92cd31a1
diff --git a/dev-haskell/tasty-golden/files/tasty-golden-2.2.1-haddock.patch b/dev-haskell/tasty-golden/files/tasty-golden-2.2.1-haddock.patch
new file mode 100644
index 000000000000..d468addf7445
--- /dev/null
+++ b/dev-haskell/tasty-golden/files/tasty-golden-2.2.1-haddock.patch
@@ -0,0 +1,11 @@
+setup: dist/doc/html/tasty-golden/haddock-prolog10293.txt: invalid argument
+diff --git a/tasty-golden.cabal b/tasty-golden.cabal
+index aa61a0a..70292f8 100644
+--- a/tasty-golden.cabal
++++ b/tasty-golden.cabal
+@@ -5 +5 @@ description:
+- This package provides support for «golden testing».
++ This package provides support for "golden testing".
+@@ -9 +9 @@ description:
+- «golden» file, which contains the correct result for the test.
++ "golden" file, which contains the correct result for the test.
diff --git a/dev-haskell/tasty-golden/metadata.xml b/dev-haskell/tasty-golden/metadata.xml
new file mode 100644
index 000000000000..14a6d43c8ea1
--- /dev/null
+++ b/dev-haskell/tasty-golden/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package provides support for «golden testing».
+ A golden test is an IO action that writes its result to a file.
+ To pass the test, this output file should be identical to the corresponding
+ 'golden' file, which contains the correct result for the test.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">feuerbach/tasty-golden</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/tasty-golden/tasty-golden-2.2.2.3.ebuild b/dev-haskell/tasty-golden/tasty-golden-2.2.2.3.ebuild
new file mode 100644
index 000000000000..c9364dcf5b8b
--- /dev/null
+++ b/dev-haskell/tasty-golden/tasty-golden-2.2.2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit base haskell-cabal
+
+DESCRIPTION="Golden tests support for tasty"
+HOMEPAGE="https://github.com/feuerbach/tasty-golden"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ dev-haskell/tagged:=[profile?]
+ >=dev-haskell/tasty-0.8:=[profile?]
+ dev-haskell/temporary-rc:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.14
+ test? ( dev-haskell/tasty-hunit )
+"
+
+PATCHES=("${FILESDIR}"/${PN}-2.2.1-haddock.patch)
diff --git a/dev-haskell/tasty-golden/tasty-golden-2.2.2.4.ebuild b/dev-haskell/tasty-golden/tasty-golden-2.2.2.4.ebuild
new file mode 100644
index 000000000000..9d29b00ef285
--- /dev/null
+++ b/dev-haskell/tasty-golden/tasty-golden-2.2.2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Golden tests support for tasty"
+HOMEPAGE="https://github.com/feuerbach/tasty-golden"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/async:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ dev-haskell/tagged:=[profile?]
+ >=dev-haskell/tasty-0.8:=[profile?]
+ dev-haskell/temporary-rc:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.14
+ test? ( dev-haskell/tasty-hunit )
+"
diff --git a/dev-haskell/tasty-golden/tasty-golden-2.3.0.1.ebuild b/dev-haskell/tasty-golden/tasty-golden-2.3.0.1.ebuild
new file mode 100644
index 000000000000..fc00187333df
--- /dev/null
+++ b/dev-haskell/tasty-golden/tasty-golden-2.3.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Golden tests support for tasty"
+HOMEPAGE="https://github.com/feuerbach/tasty-golden"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/async:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ dev-haskell/tagged:=[profile?]
+ >=dev-haskell/tasty-0.8:=[profile?]
+ dev-haskell/temporary-rc:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( dev-haskell/tasty-hunit )
+"