summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/animal-sniffer-annotations/animal-sniffer-annotations-1.15.ebuild')
-rw-r--r--dev-java/animal-sniffer-annotations/animal-sniffer-annotations-1.15.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/animal-sniffer-annotations/animal-sniffer-annotations-1.15.ebuild b/dev-java/animal-sniffer-annotations/animal-sniffer-annotations-1.15.ebuild
new file mode 100644
index 000000000000..ec63e0335ec7
--- /dev/null
+++ b/dev-java/animal-sniffer-annotations/animal-sniffer-annotations-1.15.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN%-annotations}"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java annotations for marking methods that Animal Sniffer should ignore"
+HOMEPAGE="http://www.mojohaus.org/animal-sniffer/animal-sniffer-annotations/"
+SRC_URI="https://github.com/mojohaus/${MY_PN}/archive/${MY_PN}-parent-${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/${MY_PN}-${MY_PN}-parent-${PV}/${PN}"
+JAVA_SRC_DIR="src/main/java"