summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/burlap')
-rw-r--r--dev-java/burlap/Manifest1
-rw-r--r--dev-java/burlap/burlap-3.0.8-r3.ebuild43
-rw-r--r--dev-java/burlap/files/3.0.8-java5.patch28
-rw-r--r--dev-java/burlap/metadata.xml10
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-java/burlap/Manifest b/dev-java/burlap/Manifest
new file mode 100644
index 000000000000..20e9b15b1177
--- /dev/null
+++ b/dev-java/burlap/Manifest
@@ -0,0 +1 @@
+DIST burlap-3.0.8.tar.bz2 19835 SHA256 4cdb276c9c2a33379a7cd3dfe41abde503b6745bdd47e4d08c91b2ae382ebca1 SHA512 2670686dffba16108cb825147bd483a8240142256ce30f79180e34cbbfaa957bcbdd26adaa34dc5f7027f835f8202b0d640e84b5b3f9829f4636e838b5411ad1 WHIRLPOOL 4f2f9798b03d4ab3e295fb52fde3928319c924e67dc307941ea1001dd1fc3bf305892d23b8e6ad477dd46c7ab559e96f86aa23d56224a87bccab2b8e42442972
diff --git a/dev-java/burlap/burlap-3.0.8-r3.ebuild b/dev-java/burlap/burlap-3.0.8-r3.ebuild
new file mode 100644
index 000000000000..ac7b757e5fbc
--- /dev/null
+++ b/dev-java/burlap/burlap-3.0.8-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=1
+
+inherit base java-pkg-2 java-ant-2
+
+DESCRIPTION="The Burlap web service protocol"
+HOMEPAGE="http://www.caucho.com/burlap/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="Apache-1.1"
+SLOT="3.0"
+KEYWORDS="amd64 x86"
+
+IUSE="doc source"
+
+COMMON_DEP="java-virtuals/servlet-api:2.3
+ dev-java/hessian:${PV}
+ dev-java/caucho-services:3.0"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ dev-java/ant-core
+ source? ( app-arch/zip )
+ ${COMMON_DEP}"
+
+PATCHES=( "${FILESDIR}"/3.0.8-java5.patch )
+JAVA_PKG_FILTER_COMPILER="jikes"
+
+src_compile() {
+ eant jar $(use_doc) -Dclasspath=$(java-pkg_getjars servlet-api-2.3,hessian-3.0.8,caucho-services-3.0)
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ use doc && java-pkg_dojavadoc dist/doc/api
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/burlap/files/3.0.8-java5.patch b/dev-java/burlap/files/3.0.8-java5.patch
new file mode 100644
index 000000000000..02fe38f096b8
--- /dev/null
+++ b/dev-java/burlap/files/3.0.8-java5.patch
@@ -0,0 +1,28 @@
+diff -uNr burlap-3.0.8.orig/src/com/caucho/burlap/client/BurlapProxyFactory.java burlap-3.0.8/src/com/caucho/burlap/client/BurlapProxyFactory.java
+--- burlap-3.0.8.orig/src/com/caucho/burlap/client/BurlapProxyFactory.java 2006-08-15 10:47:30.000000000 +0200
++++ burlap-3.0.8/src/com/caucho/burlap/client/BurlapProxyFactory.java 2006-08-15 10:48:19.000000000 +0200
+@@ -202,7 +202,7 @@
+ {
+ BurlapProxy handler = new BurlapProxy(this, new URL(url));
+
+- return Proxy.newProxyInstance(api.getClassLoader(),
++ return java.lang.reflect.Proxy.newProxyInstance(api.getClassLoader(),
+ new Class[] { api,
+ BurlapRemoteObject.class },
+ handler);
+diff -uNr burlap-3.0.8.orig/src/com/caucho/burlap/client/BurlapProxy.java burlap-3.0.8/src/com/caucho/burlap/client/BurlapProxy.java
+--- burlap-3.0.8.orig/src/com/caucho/burlap/client/BurlapProxy.java 2006-08-15 10:47:30.000000000 +0200
++++ burlap-3.0.8/src/com/caucho/burlap/client/BurlapProxy.java 2006-08-15 10:48:08.000000000 +0200
+@@ -94,10 +94,10 @@
+ if (methodName.equals("equals") &&
+ params.length == 1 && params[0].equals(Object.class)) {
+ Object value = args[0];
+- if (value == null || ! Proxy.isProxyClass(value.getClass()))
++ if (value == null || ! java.lang.reflect.Proxy.isProxyClass(value.getClass()))
+ return new Boolean(false);
+
+- BurlapProxy handler = (BurlapProxy) Proxy.getInvocationHandler(value);
++ BurlapProxy handler = (BurlapProxy) java.lang.reflect.Proxy.getInvocationHandler(value);
+
+ return new Boolean(_url.equals(handler.getURL()));
+ }
diff --git a/dev-java/burlap/metadata.xml b/dev-java/burlap/metadata.xml
new file mode 100644
index 000000000000..a33fead60afb
--- /dev/null
+++ b/dev-java/burlap/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ The Burlap web service protocol makes web services usable without
+ requiring a large framework, and without learning yet another
+ alphabet soup of protocols.
+ </longdescription>
+</pkgmetadata>