summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/gson/gson-2.3.1.ebuild')
-rw-r--r--dev-java/gson/gson-2.3.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-java/gson/gson-2.3.1.ebuild b/dev-java/gson/gson-2.3.1.ebuild
new file mode 100644
index 000000000000..6f4b02f15724
--- /dev/null
+++ b/dev-java/gson/gson-2.3.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java library to convert JSON to Java objects and vice-versa"
+HOMEPAGE="http://code.google.com/p/google-gson/"
+SRC_URI="http://search.maven.org/remotecontent?filepath=com/google/code/${PN}/${PN}/${PV}/${P}-sources.jar"
+LICENSE="Apache-2.0"
+SLOT="2.2.2"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.5"