summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/javahelp')
-rw-r--r--dev-java/javahelp/Manifest1
-rw-r--r--dev-java/javahelp/javahelp-2.0.05_p63.ebuild87
-rw-r--r--dev-java/javahelp/metadata.xml12
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-java/javahelp/Manifest b/dev-java/javahelp/Manifest
new file mode 100644
index 000000000000..7dc239585356
--- /dev/null
+++ b/dev-java/javahelp/Manifest
@@ -0,0 +1 @@
+DIST javahelp2-src-2.0.05_svn63.zip 3747088 SHA256 a864ac71701ed8d12ba192460cd7b4d51e78813f39a140ede5d9b04afd9eae92 SHA512 ed795dad98f8d80f4cd4cda40b6aea0978cda621b131b1563016c1ddc02afeb37f3626a28003dac26d7fe996274fb9a97e741a500b15d06b1e5a93342020abc3 WHIRLPOOL 111398f9e6731749af6a0f36b59cd5a609c8fd203b03fc219bac02a456e2ae92718acac2f75debe768c978a14fb000ad7ea9b7eb0b94f6b6f4d8c1f95a0bafc6
diff --git a/dev-java/javahelp/javahelp-2.0.05_p63.ebuild b/dev-java/javahelp/javahelp-2.0.05_p63.ebuild
new file mode 100644
index 000000000000..4bf1748c0ed4
--- /dev/null
+++ b/dev-java/javahelp/javahelp-2.0.05_p63.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+WANT_ANT_TASKS="ant-nodeps"
+JAVA_PKG_IUSE="doc examples source"
+
+inherit versionator java-pkg-2 java-ant-2
+
+DESCRIPTION="The JavaHelp system online help system"
+HOMEPAGE="https://javahelp.dev.java.net/"
+
+MY_PV="${PV/_p/_svn}"
+MY_PN="${PN}2"
+SRC_URI="https://${PN}.dev.java.net/files/documents/5985/145533/${MY_PN}-src-${MY_PV}.zip"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+COMMON_DEP="
+ java-virtuals/servlet-api:2.4"
+RDEPEND="
+ >=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND="
+ >=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}/"
+BDIR="${S}/javahelp_nbproject"
+
+src_unpack() {
+ unpack ${A}
+ # jdic does not currently build out of the box against the browsers we have
+ cd "${S}/jhMaster/JavaHelp/src/new/" || die
+ rm -v javax/help/plaf/basic/BasicNativeContentViewerUI.java || die
+ mkdir "${BDIR}/lib" && cd "${BDIR}/lib" || die
+ java-pkg_jar-from --virtual servlet-api-2.4
+ java-pkg_filter-compiler jikes
+}
+
+_eant() {
+ cd ${BDIR} || die
+ eant \
+ -Dservlet-jar="$(java-pkg_getjar --virtual servlet-api-2.4 servlet-api.jar)" \
+ -Djsp-jar="$(java-pkg_getjar --virtual servlet-api-2.4 jsp-api.jar)" \
+ -Djdic-jar-present=true \
+ -Djdic-zip-present=true \
+ -Dtomcat-zip-present=true \
+ -Dservlet-jar-present=true \
+ ${@}
+}
+
+src_compile() {
+ _eant release $(use_doc)
+}
+
+#Does not actually run anything
+#src_test() {
+# _eant test
+#}
+
+src_install() {
+ pushd jhMaster/JavaHelp >/dev/null || die
+ java-pkg_dojar "${BDIR}"/dist/lib/*.jar
+ java-pkg_dolauncher jhsearch \
+ --main com.sun.java.help.search.QueryEngine
+ java-pkg_dolauncher jhindexer \
+ --main com.sun.java.help.search.Indexer
+ use doc && java-pkg_dojavadoc "${BDIR}/dist/lib/javadoc"
+ popd >/dev/null || die
+
+ use source && java-pkg_dosrc \
+ ./jhMaster/JSearch/*/com \
+ ./jhMaster/JavaHelp/src/*/{javax,com}
+ use examples && java-pkg_doexamples jhMaster/JavaHelp/demos
+}
+
+pkg_postinst() {
+ elog "Native browser integration is disabled because it needs jdic"
+ elog "which does not build out of the box. See"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=53897 for progress"
+}
diff --git a/dev-java/javahelp/metadata.xml b/dev-java/javahelp/metadata.xml
new file mode 100644
index 000000000000..fc5ba13dc08f
--- /dev/null
+++ b/dev-java/javahelp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ The JavaHelp system is an online help system that developers can
+ use to add online help to their Java platform applications. The
+ JavaHelp system is both a JCP specification (JSR 97) and a reference
+ implementation of that specification. The JavaHelp system open source
+ project includes the source to the reference implementation.
+ </longdescription>
+</pkgmetadata>