summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jsr311-api')
-rw-r--r--dev-java/jsr311-api/Manifest1
-rw-r--r--dev-java/jsr311-api/files/jsr311-api-1.0-build.xml26
-rw-r--r--dev-java/jsr311-api/files/jsr311-api-1.0-manifest17
-rw-r--r--dev-java/jsr311-api/files/jsr311-api-1.0-maven-build.xml183
-rw-r--r--dev-java/jsr311-api/files/jsr311-api-1.1-build.xml26
-rw-r--r--dev-java/jsr311-api/files/jsr311-api-1.1-manifest17
-rw-r--r--dev-java/jsr311-api/files/jsr311-api-1.1-maven-build.xml183
-rw-r--r--dev-java/jsr311-api/jsr311-api-1.1.ebuild61
-rw-r--r--dev-java/jsr311-api/metadata.xml8
9 files changed, 522 insertions, 0 deletions
diff --git a/dev-java/jsr311-api/Manifest b/dev-java/jsr311-api/Manifest
new file mode 100644
index 000000000000..8d3a9823d6d9
--- /dev/null
+++ b/dev-java/jsr311-api/Manifest
@@ -0,0 +1 @@
+DIST jsr311-api-1.1-src.tar.bz2 84225 SHA256 c048e69dae1282e345de8cc169d3ead0a2bde9054b385b8b15f24074d4c779ef SHA512 d7d07b1587914f1b060fb780eb96aae98d4d6d78c6f40822bc5e60e1eb2d0956fe048c7dc3f21a8e40160d67ca208eb2e731ae72215e52a7c545eac79ca4ba76 WHIRLPOOL 4cc66526547dbcefa6f1a300c8d16e6ae3e95423a23d2452fc4fbb0a449af84bff6fb739d167e5f0718bfcfa43d58d379bf24e4a3ed85ead81ff0779105def4e
diff --git a/dev-java/jsr311-api/files/jsr311-api-1.0-build.xml b/dev-java/jsr311-api/files/jsr311-api-1.0-build.xml
new file mode 100644
index 000000000000..00ededecdc10
--- /dev/null
+++ b/dev-java/jsr311-api/files/jsr311-api-1.0-build.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- Ant build modified for Gentoo @ Mon, 23 Feb 2009 08:35:22 +0000 -->
+<!-- Robin H. Johnson <robbat2@gentoo.org> -->
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<project name="jsr311-api" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Import maven-build.xml into the current project -->
+ <!-- ====================================================================== -->
+
+ <import file="maven-build.xml"/>
+
+ <!-- ====================================================================== -->
+ <!-- Help target -->
+ <!-- ====================================================================== -->
+
+ <target name="help">
+ <echo message="Please run: $ant -projecthelp"/>
+ </target>
+
+</project>
diff --git a/dev-java/jsr311-api/files/jsr311-api-1.0-manifest b/dev-java/jsr311-api/files/jsr311-api-1.0-manifest
new file mode 100644
index 000000000000..9c4e64da9610
--- /dev/null
+++ b/dev-java/jsr311-api/files/jsr311-api-1.0-manifest
@@ -0,0 +1,17 @@
+Manifest-Version: 1.0
+Extension-Name: javax.ws.rs
+Specification-Title: JAX-RS: Java API for RESTful Web Services
+Specification-Vendor: Sun Microsystems, Inc.
+Specification-Version: 1.0
+Bundle-DocURL: http://www.sun.com/
+Bundle-License: http://www.opensource.org/licenses/cddl1.php
+Bundle-ManifestVersion: 2
+Bundle-Name: jsr311-api
+Bundle-SymbolicName: javax.ws.rs.jsr311-api
+Bundle-Vendor: Sun Microsystems, Inc
+Bundle-Version: 1.0
+Import-Package: javax.ws.rs;version="1.0",javax.ws.rs.core;version="1.
+ 0",javax.ws.rs.ext;version="1.0"
+Export-Package: javax.ws.rs;uses:="javax.ws.rs.core";version="1.0",jav
+ ax.ws.rs.ext;uses:="javax.ws.rs,javax.ws.rs.core";version="1.0",javax
+ .ws.rs.core;uses:="javax.ws.rs,javax.ws.rs.ext";version="1.0"
diff --git a/dev-java/jsr311-api/files/jsr311-api-1.0-maven-build.xml b/dev-java/jsr311-api/files/jsr311-api-1.0-maven-build.xml
new file mode 100644
index 000000000000..d8761bdf621e
--- /dev/null
+++ b/dev-java/jsr311-api/files/jsr311-api-1.0-maven-build.xml
@@ -0,0 +1,183 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- Ant build modified for Gentoo @ Mon, 23 Feb 2009 08:35:22 +0000 -->
+<!-- Robin H. Johnson <robbat2@gentoo.org> -->
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<project name="jsr311-api-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jsr311-api-1.0"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="test"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ </path>
+ <path id="build.test.classpath">
+ <fileset dir=".">
+ <include name="lib/junit.jar"/>
+ </fileset>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5"
+ classpath="${gentoo.classpath}">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5"
+ classpath="${gentoo.classpath}">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ manifest="manifest"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+</project>
diff --git a/dev-java/jsr311-api/files/jsr311-api-1.1-build.xml b/dev-java/jsr311-api/files/jsr311-api-1.1-build.xml
new file mode 100644
index 000000000000..00ededecdc10
--- /dev/null
+++ b/dev-java/jsr311-api/files/jsr311-api-1.1-build.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- Ant build modified for Gentoo @ Mon, 23 Feb 2009 08:35:22 +0000 -->
+<!-- Robin H. Johnson <robbat2@gentoo.org> -->
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<project name="jsr311-api" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Import maven-build.xml into the current project -->
+ <!-- ====================================================================== -->
+
+ <import file="maven-build.xml"/>
+
+ <!-- ====================================================================== -->
+ <!-- Help target -->
+ <!-- ====================================================================== -->
+
+ <target name="help">
+ <echo message="Please run: $ant -projecthelp"/>
+ </target>
+
+</project>
diff --git a/dev-java/jsr311-api/files/jsr311-api-1.1-manifest b/dev-java/jsr311-api/files/jsr311-api-1.1-manifest
new file mode 100644
index 000000000000..93184153e14c
--- /dev/null
+++ b/dev-java/jsr311-api/files/jsr311-api-1.1-manifest
@@ -0,0 +1,17 @@
+Manifest-Version: 1.0
+Extension-Name: javax.ws.rs
+Specification-Title: JAX-RS: Java API for RESTful Web Services
+Specification-Vendor: Sun Microsystems, Inc.
+Specification-Version: 1.1
+Bundle-License: http://www.opensource.org/licenses/cddl1.php
+Import-Package: javax.ws.rs;version="1.1",javax.ws.rs.core;version="1.
+ 0",javax.ws.rs.ext;version="1.1"
+Export-Package: javax.ws.rs;uses:="javax.ws.rs.core";version="1.1",jav
+ ax.ws.rs.ext;uses:="javax.ws.rs,javax.ws.rs.core";version="1.1",javax
+ .ws.rs.core;uses:="javax.ws.rs,javax.ws.rs.ext";version="1.1"
+Bundle-Version: 1.1
+Bundle-Name: jsr311-api
+Bundle-DocURL: http://www.sun.com/
+Bundle-ManifestVersion: 2
+Bundle-Vendor: Sun Microsystems, Inc
+Bundle-SymbolicName: javax.ws.rs.jsr311-api
diff --git a/dev-java/jsr311-api/files/jsr311-api-1.1-maven-build.xml b/dev-java/jsr311-api/files/jsr311-api-1.1-maven-build.xml
new file mode 100644
index 000000000000..326cfda665c2
--- /dev/null
+++ b/dev-java/jsr311-api/files/jsr311-api-1.1-maven-build.xml
@@ -0,0 +1,183 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- Ant build modified for Gentoo @ Mon, 23 Feb 2009 08:35:22 +0000 -->
+<!-- Robin H. Johnson <robbat2@gentoo.org> -->
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<project name="jsr311-api-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jsr311-api-1.1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="test"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ </path>
+ <path id="build.test.classpath">
+ <fileset dir=".">
+ <include name="lib/junit.jar"/>
+ </fileset>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5"
+ classpath="${gentoo.classpath}">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5"
+ classpath="${gentoo.classpath}">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ manifest="manifest"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+</project>
diff --git a/dev-java/jsr311-api/jsr311-api-1.1.ebuild b/dev-java/jsr311-api/jsr311-api-1.1.ebuild
new file mode 100644
index 000000000000..c3b7c4edf618
--- /dev/null
+++ b/dev-java/jsr311-api/jsr311-api-1.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source test"
+PROJ_PN="jsr311"
+PROJ_PV="${PV}"
+PROJ_P="${PROJ_PN}-${PROJ_PV}"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JAX-RS: Java API for RESTful Web Services"
+HOMEPAGE="https://jsr311.dev.java.net/"
+SRC_FILE="${P}-src.tar.bz2"
+SRC_URI="mirror://gentoo/${SRC_FILE}"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5
+ test? ( dev-java/ant-junit:0 dev-java/junit:0 )"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${P}/${PN}"
+
+# Helper to generate the tarball :-)
+# ( PN=jsr311-api ; PV=1.1 ; P="${PN}-${PV}" ; . ${P}.ebuild ; src_tarball )
+src_tarball() {
+ SVN_SRC_URI="${HOMEPAGE}/svn/${PROJ_PN}/tags/${P}"
+ tarball="${P}"
+ svn export \
+ --username guest --password '' --non-interactive \
+ ${SVN_SRC_URI} ${tarball} \
+ && \
+ tar cvjf ${SRC_FILE} ${tarball} \
+ && \
+ echo "New tarball located at ${SRC_FILE}"
+}
+
+java_prepare() {
+ for i in build.xml maven-build.xml manifest ; do
+ cp -f "${FILESDIR}"/"${P}-${i}" "${i}" \
+ || die "Unable to find ${P}-${i}"
+ done
+}
+
+src_install() {
+ dodoc README.txt || die
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/javax
+}
+
+src_test() {
+ EANT_GENTOO_CLASSPATH="junit ant-core" \
+ ANT_TASKS="ant-junit" \
+ eant test
+}
diff --git a/dev-java/jsr311-api/metadata.xml b/dev-java/jsr311-api/metadata.xml
new file mode 100644
index 000000000000..0f01f6e07537
--- /dev/null
+++ b/dev-java/jsr311-api/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>