summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/sax')
-rw-r--r--dev-java/sax/sax-2.2.1-r4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/sax/sax-2.2.1-r4.ebuild b/dev-java/sax/sax-2.2.1-r4.ebuild
new file mode 100644
index 000000000000..2142cba424fd
--- /dev/null
+++ b/dev-java/sax/sax-2.2.1-r4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+MY_PN="sax2r3"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="SAX: Simple API for XML in Java"
+HOMEPAGE="http://sax.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}.zip -> ${P}.zip"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/sax2r3"
+
+src_prepare() {
+ default
+ java-pkg_clean
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc ChangeLog CHANGES README
+}