summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/swing-layout/swing-layout-1.0.4-r2.ebuild')
-rw-r--r--dev-java/swing-layout/swing-layout-1.0.4-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/swing-layout/swing-layout-1.0.4-r2.ebuild b/dev-java/swing-layout/swing-layout-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..e7338fbad6a8
--- /dev/null
+++ b/dev-java/swing-layout/swing-layout-1.0.4-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Professional cross platform layouts with Swing"
+HOMEPAGE="https://swing-layout.dev.java.net/"
+SRC_URI="mirror://gentoo/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ >=virtual/jdk-1.8:*"
+
+RDEPEND="
+ >=virtual/jre-1.8:*"
+
+BDEPEND="
+ app-arch/unzip"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src"