summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/vecmath/vecmath-1.6.0_pre12.ebuild')
-rw-r--r--dev-java/vecmath/vecmath-1.6.0_pre12.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-java/vecmath/vecmath-1.6.0_pre12.ebuild b/dev-java/vecmath/vecmath-1.6.0_pre12.ebuild
deleted file mode 100644
index a6cfc8778ec7..000000000000
--- a/dev-java/vecmath/vecmath-1.6.0_pre12.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Sun J3D: 3D vector math package"
-HOMEPAGE="https://vecmath.dev.java.net/"
-
-MY_PV=$(replace_version_separator 3 '-')
-SRC_URI="https://github.com/hharrison/vecmath/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND=">=virtual/jdk-1.6
- dev-java/ant-core"
-RDEPEND=">=virtual/jre-1.6"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-EANT_DOC_TARGET="docs"
-EANT_BUILD_TARGET="jar"
-
-src_install() {
- java-pkg_dojar "build/jars/${PN}.jar"
-
- use source && java-pkg_dosrc "${S}/src/*"
-
- dodoc *.txt docs/*.txt
- if use doc; then
- java-pkg_dojavadoc "build/javadoc/"
- dohtml -r *.html
- fi
-}