summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/cxprolog/files/cxprolog-0.98.2-portage.patch')
-rw-r--r--dev-lang/cxprolog/files/cxprolog-0.98.2-portage.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-lang/cxprolog/files/cxprolog-0.98.2-portage.patch b/dev-lang/cxprolog/files/cxprolog-0.98.2-portage.patch
new file mode 100644
index 000000000000..ed9fb3864c69
--- /dev/null
+++ b/dev-lang/cxprolog/files/cxprolog-0.98.2-portage.patch
@@ -0,0 +1,52 @@
+--- cxprolog-0.98.2.orig/Makefile 2016-09-17 20:33:35.000000000 +0200
++++ cxprolog-0.98.2/Makefile 2020-07-18 18:18:02.605499273 +0200
+@@ -20,9 +20,9 @@
+ ######################################################################
+
+ ##############################################################################
+-# To disable READLINE SUPPORT, uncomment the following line:
++# For READLINE SUPPORT, uncomment the following line:
+ #
+-# READLINE := n
++# READLINE := y
+ #
+ # Nothing more is required.
+ # This functionality is active by default.
+@@ -165,8 +165,7 @@
+ ZLIBS := $(EXTRA) $(LIBS) $(EXT_LIBS)
+ ZPRE :=
+
+-ifeq ($(READLINE),n)
+-else
++ifeq ($(READLINE),y)
+ ifneq ($(OS),MINGW32)
+ ifeq ($(shell if test -e "/usr/local/opt/readline"; then echo "y" ; fi),y)
+ ZDEFINES += -DUSE_READLINE=4 -I/usr/local/opt/readline/include
+@@ -329,7 +328,7 @@
+ endif
+
+ cxprolog_testlib.exe: libcxprolog.a cxprolog.dll
+- gcc -DTESTLIB=1 -o src/TestLib.o -c src/TestLib.c
++ $(CC) -DTESTLIB=1 -o src/TestLib.o -c src/TestLib.c
+ $(CPP) -enable-auto-import -o cxprolog_testlib src/TestLib.o -L./ -lcxprolog
+ rm src/TestLib.o
+
+@@ -337,14 +336,14 @@
+
+ else # Assume Unix
+ libcxprolog.so: $(OBJ_DIR) $(OBJS)
+- $(CPP) -shared -o libcxprolog.so $(OBJS) -lc $(ZLIBS)
++ $(CPP) -shared -Wl,-soname,libcxprolog.so -o libcxprolog.so $(filter-out src/obj/CxProlog.o,$(OBJS)) -lc $(ZLIBS)
+
+ cxprolog_shared: libcxprolog.so
+- $(CPP) $(ZDEFINES) -o cxprolog_shared -L./ -lcxprolog
++ $(CPP) $(ZDEFINES) -o cxprolog_shared src/obj/CxProlog.o -L./ -lcxprolog $(ZLIBS)
+
+ cxprolog_testlib: libcxprolog.so
+- gcc $(ZDEFINES) -DTESTLIB=1 -o src/TestLib.o -c src/TestLib.c
+- $(CPP) $(ZDEFINES) -o cxprolog_testlib src/TestLib.o -L./ -lcxprolog
++ $(CC) $(ZDEFINES) -DTESTLIB=1 -o src/TestLib.o -c src/TestLib.c
++ $(CPP) $(ZDEFINES) -o cxprolog_testlib src/TestLib.o -L./ -lcxprolog $(ZLIBS)
+ rm src/TestLib.o
+
+ lib: libcxprolog.so cxprolog_shared cxprolog_testlib