summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/fsharp/fsharp-4.0.1.1.ebuild')
-rw-r--r--dev-lang/fsharp/fsharp-4.0.1.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-lang/fsharp/fsharp-4.0.1.1.ebuild b/dev-lang/fsharp/fsharp-4.0.1.1.ebuild
new file mode 100644
index 000000000000..f3660d8bf7d3
--- /dev/null
+++ b/dev-lang/fsharp/fsharp-4.0.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils mono-env
+
+DESCRIPTION="The F# Compiler"
+HOMEPAGE="https://github.com/fsharp/fsharp"
+SRC_URI="https://github.com/fsharp/fsharp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+MAKEOPTS+=" -j1" #nowarn
+DEPEND=">=dev-lang/mono-3"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_install() {
+ autotools-utils_src_install
+}