summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/go/go-1.6.1.ebuild')
-rw-r--r--dev-lang/go/go-1.6.1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-lang/go/go-1.6.1.ebuild b/dev-lang/go/go-1.6.1.ebuild
index 0cf5b7c56094..c70fc26e5293 100644
--- a/dev-lang/go/go-1.6.1.ebuild
+++ b/dev-lang/go/go-1.6.1.ebuild
@@ -152,7 +152,7 @@ src_compile()
export GOROOT_BOOTSTRAP="${WORKDIR}"/go-$(go_os)-$(go_arch)-bootstrap
if use gccgo; then
mkdir -p "${GOROOT_BOOTSTRAP}/bin" || die
- local go_binary=$(type -P go-5 2>/dev/null)
+ local go_binary=$(gcc-config --get-bin-path)/go-5
[[ -x ${go_binary} ]] || go_binary=$(
find "${EPREFIX}"/usr/${CHOST}/gcc-bin/*/go-5 | sort -V | tail -n1)
[[ -x ${go_binary} ]] || die "go-5: command not found"