summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/haxe')
-rw-r--r--dev-lang/haxe/haxe-4.2.4-r2.ebuild (renamed from dev-lang/haxe/haxe-4.2.4-r1.ebuild)7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-lang/haxe/haxe-4.2.4-r1.ebuild b/dev-lang/haxe/haxe-4.2.4-r2.ebuild
index b391ef467182..6a8441c77ab2 100644
--- a/dev-lang/haxe/haxe-4.2.4-r1.ebuild
+++ b/dev-lang/haxe/haxe-4.2.4-r2.ebuild
@@ -48,7 +48,11 @@ QA_FLAGS_IGNORED="usr/bin/haxelib"
QA_PRESTRIPPED="usr/bin/haxelib"
src_configure() {
- use ocamlopt && export OCAMLOPT=ocamlopt.opt
+ if use ocamlopt ; then
+ export OCAMLOPT=ocamlopt.opt
+ else
+ export OCAMLOPT=ocamlopt
+ fi
}
src_compile() {
@@ -56,6 +60,7 @@ src_compile() {
BRANCH=""
COMMIT_DATE=""
COMMIT_SHA=""
+ OCAMLOPT=${OCAMLOPT}
INSTALL_DIR=/usr
)
emake -j1