summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/mozart/mozart-2.0.1.ebuild')
-rw-r--r--dev-lang/mozart/mozart-2.0.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/mozart/mozart-2.0.1.ebuild b/dev-lang/mozart/mozart-2.0.1.ebuild
index e6b2dc3f4425..ebd5d3b04736 100644
--- a/dev-lang/mozart/mozart-2.0.1.ebuild
+++ b/dev-lang/mozart/mozart-2.0.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit cmake-utils java-pkg-2 java-ant-2
-PATCHSET_VER="0"
+PATCHSET_VER="1"
DESCRIPTION="Advanced development platform for intelligent, distributed applications"
HOMEPAGE="http://mozart2.org/"
@@ -28,8 +28,8 @@ DEPEND="${RDEPEND}
dev-java/ant-core
>=virtual/jdk-1.8:=
|| (
- dev-lang/scala
- dev-lang/scala-bin
+ dev-lang/scala:2.12
+ dev-lang/scala-bin:0
)
test? ( dev-cpp/gtest:= )"
@@ -60,7 +60,7 @@ src_configure() {
src_compile() {
if has_version "dev-lang/scala"; then
- EANT_GENTOO_CLASSPATH="scala"
+ EANT_GENTOO_CLASSPATH="scala:2.12"
else
EANT_GENTOO_CLASSPATH="scala-bin"
fi