summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-2.7.9-r1.ebuild')
-rw-r--r--dev-lang/python/python-2.7.9-r1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-lang/python/python-2.7.9-r1.ebuild b/dev-lang/python/python-2.7.9-r1.ebuild
index 20cdedb0ea7f..1e9eb6ae3249 100644
--- a/dev-lang/python/python-2.7.9-r1.ebuild
+++ b/dev-lang/python/python-2.7.9-r1.ebuild
@@ -315,16 +315,18 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON
- export PYTHON_SITEDIR="${EPREFIX}/usr/$(get_libdir)/python${SLOT}/site-packages"
+ local vars=( EPYTHON PYTHON_SITEDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ python_export "python${PYVER}" "${vars[@]}"
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
}