summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust/rust-1.10.0.ebuild')
-rw-r--r--dev-lang/rust/rust-1.10.0.ebuild154
1 files changed, 0 insertions, 154 deletions
diff --git a/dev-lang/rust/rust-1.10.0.ebuild b/dev-lang/rust/rust-1.10.0.ebuild
deleted file mode 100644
index 58775d26c059..000000000000
--- a/dev-lang/rust/rust-1.10.0.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-any-r1 versionator toolchain-funcs
-
-if [[ ${PV} = *beta* ]]; then
- betaver=${PV//*beta}
- BETA_SNAPSHOT="${betaver:0:4}-${betaver:4:2}-${betaver:6:2}"
- MY_P="rustc-beta"
- SLOT="beta/${PV}"
- SRC="${BETA_SNAPSHOT}/rustc-beta-src.tar.gz"
- KEYWORDS=""
-else
- ABI_VER="$(get_version_component_range 1-2)"
- SLOT="stable/${ABI_VER}"
- MY_P="rustc-${PV}"
- SRC="${MY_P}-src.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-STAGE0_VERSION="1.$(($(get_version_component_range 2) - 1)).0"
-RUST_STAGE0_amd64="rustc-${STAGE0_VERSION}-x86_64-unknown-linux-gnu"
-RUST_STAGE0_x86="rustc-${STAGE0_VERSION}-i686-unknown-linux-gnu"
-
-DESCRIPTION="Systems programming language from Mozilla"
-HOMEPAGE="http://www.rust-lang.org/"
-
-SRC_URI="https://static.rust-lang.org/dist/${SRC} -> rustc-${PV}-src.tar.gz
- amd64? ( https://static.rust-lang.org/dist/${RUST_STAGE0_amd64}.tar.gz )
- x86? ( https://static.rust-lang.org/dist/${RUST_STAGE0_x86}.tar.gz )
-"
-
-LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
-
-IUSE="clang debug doc libcxx +system-llvm"
-REQUIRED_USE="libcxx? ( clang )"
-
-RDEPEND="libcxx? ( sys-libs/libcxx )
- system-llvm? ( >=sys-devel/llvm-3.7.1-r1:=[multitarget]
- <sys-devel/llvm-3.9.0:=[multitarget] )
-"
-
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- >=dev-lang/perl-5.0
- clang? ( sys-devel/clang )
-"
-
-PDEPEND=">=app-eselect/eselect-rust-0.3_pre20150425"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack "rustc-${PV}-src.tar.gz" || die
- mkdir "${MY_P}/dl" || die
- local stagename="RUST_STAGE0_${ARCH}"
- local stage0="${!stagename}"
- cp "${DISTDIR}/${stage0}.tar.gz" "${MY_P}/dl/" || die "cp stage0"
-}
-
-src_prepare() {
- find mk -name '*.mk' -exec \
- sed -i -e "s/-Werror / /g" {} \; || die
-
- eapply_user
-}
-
-src_configure() {
- export CFG_DISABLE_LDCONFIG="notempty"
-
- "${ECONF_SOURCE:-.}"/configure \
- --prefix="${EPREFIX}/usr" \
- --libdir="${EPREFIX}/usr/$(get_libdir)/${P}" \
- --mandir="${EPREFIX}/usr/share/${P}/man" \
- --release-channel=${SLOT%%/*} \
- --disable-manage-submodules \
- --default-linker=$(tc-getBUILD_CC) \
- --default-ar=$(tc-getBUILD_AR) \
- --python=${EPYTHON} \
- --disable-rpath \
- $(use_enable clang) \
- $(use_enable debug) \
- $(use_enable debug llvm-assertions) \
- $(use_enable !debug optimize) \
- $(use_enable !debug optimize-cxx) \
- $(use_enable !debug optimize-llvm) \
- $(use_enable !debug optimize-tests) \
- $(use_enable doc docs) \
- $(use_enable libcxx libcpp) \
- $(usex system-llvm "--llvm-root=${EPREFIX}/usr" " ") \
- || die
-}
-
-src_compile() {
- emake VERBOSE=1
-}
-
-src_install() {
- unset SUDO_USER
-
- default
-
- mv "${D}/usr/bin/rustc" "${D}/usr/bin/rustc-${PV}" || die
- mv "${D}/usr/bin/rustdoc" "${D}/usr/bin/rustdoc-${PV}" || die
- mv "${D}/usr/bin/rust-gdb" "${D}/usr/bin/rust-gdb-${PV}" || die
-
- dodoc COPYRIGHT
-
- dodir "/usr/share/doc/rust-${PV}/"
- mv "${D}/usr/share/doc/rust"/* "${D}/usr/share/doc/rust-${PV}/" || die
- rmdir "${D}/usr/share/doc/rust/" || die
-
- cat <<-EOF > "${T}"/50${P}
- LDPATH="/usr/$(get_libdir)/${P}"
- MANPATH="/usr/share/${P}/man"
- EOF
- doenvd "${T}"/50${P}
-
- cat <<-EOF > "${T}/provider-${P}"
- /usr/bin/rustdoc
- /usr/bin/rust-gdb
- EOF
- dodir /etc/env.d/rust
- insinto /etc/env.d/rust
- doins "${T}/provider-${P}"
-}
-
-pkg_postinst() {
- eselect rust update --if-unset
-
- elog "Rust installs a helper script for calling GDB now,"
- elog "for your convenience it is installed under /usr/bin/rust-gdb-${PV}."
-
- if has_version app-editors/emacs || has_version app-editors/emacs-vcs; then
- elog "install app-emacs/rust-mode to get emacs support for rust."
- fi
-
- if has_version app-editors/gvim || has_version app-editors/vim; then
- elog "install app-vim/rust-vim to get vim support for rust."
- fi
-
- if has_version 'app-shells/zsh'; then
- elog "install app-shells/rust-zshcomp to get zsh completion for rust."
- fi
-}
-
-pkg_postrm() {
- eselect rust unset --if-invalid
-}