summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust/rust-1.47.0.ebuild')
-rw-r--r--dev-lang/rust/rust-1.47.0.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/dev-lang/rust/rust-1.47.0.ebuild b/dev-lang/rust/rust-1.47.0.ebuild
index bc0dd9a95b40..a5041ff03fed 100644
--- a/dev-lang/rust/rust-1.47.0.ebuild
+++ b/dev-lang/rust/rust-1.47.0.ebuild
@@ -133,6 +133,7 @@ toml_usex() {
boostrap_rust_version_check() {
# never call from pkg_pretend. eselect-rust may be not installed yet.
+ [[ ${MERGE_TYPE} == binary ]] && return
local rustc_wanted="$(ver_cut 1).$(($(ver_cut 2) - 1))"
local rustc_version=( $(eselect --brief rust show 2>/dev/null) )
rustc_version=${rustc_version[0]#rust-bin-}