summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/spidermonkey/files/spidermonkey-24.2.0-fix-file-permissions.patch')
-rw-r--r--dev-lang/spidermonkey/files/spidermonkey-24.2.0-fix-file-permissions.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lang/spidermonkey/files/spidermonkey-24.2.0-fix-file-permissions.patch b/dev-lang/spidermonkey/files/spidermonkey-24.2.0-fix-file-permissions.patch
new file mode 100644
index 000000000000..a2247164111a
--- /dev/null
+++ b/dev-lang/spidermonkey/files/spidermonkey-24.2.0-fix-file-permissions.patch
@@ -0,0 +1,29 @@
+diff -urN a/js/src/Makefile.in b/js/src/Makefile.in
+--- a/js/src/Makefile.in 2013-11-19 13:42:43.000000000 -0600
++++ b/js/src/Makefile.in 2014-03-08 08:07:28.331006149 -0600
+@@ -542,7 +542,7 @@
+ $(PYTHON) $(topsrcdir)/config/Preprocessor.py $(JS_CONFIG_SUBSTITUTIONS) $< > $@
+
+ install:: $(LIBRARY_NAME).pc
+- $(SYSINSTALL) $^ $(DESTDIR)$(libdir)/pkgconfig
++ $(SYSINSTALL) -m 0644 $^ $(DESTDIR)$(libdir)/pkgconfig
+
+ ######################################################
+ # BEGIN SpiderMonkey header installation
+@@ -569,13 +569,13 @@
+ #
+
+ install:: $(EXPORTS)
+- $(SYSINSTALL) $^ $(DESTDIR)$(includedir)/$(LIBRARY_NAME)
++ $(SYSINSTALL) -m 0644 $^ $(DESTDIR)$(includedir)/$(LIBRARY_NAME)
+
+ install:: $(EXPORTS_js)
+- $(SYSINSTALL) $^ $(DESTDIR)$(includedir)/$(LIBRARY_NAME)/js
++ $(SYSINSTALL) -m 0644 $^ $(DESTDIR)$(includedir)/$(LIBRARY_NAME)/js
+
+ install:: $(EXPORTS_mozilla)
+- $(SYSINSTALL) $^ $(DESTDIR)$(includedir)/$(LIBRARY_NAME)/mozilla
++ $(SYSINSTALL) -m 0644 $^ $(DESTDIR)$(includedir)/$(LIBRARY_NAME)/mozilla
+
+ #
+ # END SpiderMonkey header installation