summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/OpenNI/files/jpeg.patch')
-rw-r--r--dev-libs/OpenNI/files/jpeg.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/OpenNI/files/jpeg.patch b/dev-libs/OpenNI/files/jpeg.patch
new file mode 100644
index 000000000000..46f5dfd3d873
--- /dev/null
+++ b/dev-libs/OpenNI/files/jpeg.patch
@@ -0,0 +1,23 @@
+Index: OpenNI-9999/Platform/Linux/Build/Modules/nimCodecs/Makefile
+===================================================================
+--- OpenNI-9999.orig/Platform/Linux/Build/Modules/nimCodecs/Makefile
++++ OpenNI-9999/Platform/Linux/Build/Modules/nimCodecs/Makefile
+@@ -2,15 +2,13 @@ BIN_DIR = ../../../Bin
+
+ INC_DIRS = \
+ ../../../../../Include \
+- ../../../../../Source \
+- ../../../../../Externals/LibJPEG
++ ../../../../../Source
+
+ SRC_FILES = \
+- ../../../../../Source/Modules/nimCodecs/*.cpp \
+- ../../../../../Externals/LibJPEG/*.c
++ ../../../../../Source/Modules/nimCodecs/*.cpp
+
+ LIB_NAME = nimCodecs
+-USED_LIBS = OpenNI
++USED_LIBS = OpenNI jpeg
+
+ include ../../Common/CommonCppMakefile
+