summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild')
-rw-r--r--dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild b/dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild
index 69a3ccb8f34f..a5e42cb20751 100644
--- a/dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild
+++ b/dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit autotools java-pkg-opt-2 python-single-r1
+inherit autotools flag-o-matic java-pkg-opt-2 python-single-r1
DESCRIPTION="General-purpose cryptography library"
HOMEPAGE="https://sourceforge.net/projects/beecrypt/"
@@ -52,6 +52,10 @@ src_prepare() {
}
src_configure() {
+ # ICU needs char16_t support now
+ # bug 649548
+ append-cxxflags -std=c++14
+
# cplusplus needs threads support
econf \
--disable-expert-mode \