summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/confuse/confuse-3.2.1.ebuild')
-rw-r--r--dev-libs/confuse/confuse-3.2.1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-libs/confuse/confuse-3.2.1.ebuild b/dev-libs/confuse/confuse-3.2.1.ebuild
deleted file mode 100644
index 576798947c01..000000000000
--- a/dev-libs/confuse/confuse-3.2.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils multilib-minimal
-
-DESCRIPTION="a configuration file parser library"
-HOMEPAGE="https://github.com/martinh/libconfuse"
-SRC_URI="${HOMEPAGE}/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="ISC"
-SLOT="0/2.0.0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-
-IUSE="nls static-libs"
-
-DEPEND="sys-devel/flex
- sys-devel/libtool
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-RDEPEND="nls? ( virtual/libintl[${MULTILIB_USEDEP}] )"
-
-DOCS=( AUTHORS )
-
-src_prepare() {
- eapply_user
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- # examples are normally compiled but not installed. They
- # fail during a mingw crosscompile.
- local ECONF_SOURCE=${BUILD_DIR}
- econf \
- --enable-shared \
- --disable-examples \
- $(use_enable nls) \
- $(use_enable static-libs static)
-}
-
-multilib_src_install_all() {
- prune_libtool_files
-
- doman doc/man/man3/*.3
- dodoc -r doc/html
-
- docinto examples
- dodoc examples/*.{c,conf}
-}