summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/cudnn-frontend/cudnn-frontend-0.9.2.ebuild')
-rw-r--r--dev-libs/cudnn-frontend/cudnn-frontend-0.9.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-libs/cudnn-frontend/cudnn-frontend-0.9.2.ebuild b/dev-libs/cudnn-frontend/cudnn-frontend-0.9.2.ebuild
new file mode 100644
index 000000000000..0ad71cab6763
--- /dev/null
+++ b/dev-libs/cudnn-frontend/cudnn-frontend-0.9.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A c++ wrapper for the cudnn backend API"
+HOMEPAGE="https://github.com/NVIDIA/cudnn-frontend"
+SRC_URI="https://github.com/NVIDIA/cudnn-frontend/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/8"
+KEYWORDS="~amd64"
+
+RDEPEND="=dev-libs/cudnn-8*"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ insinto /opt/cuda/targets/x86_64-linux
+ doins -r include
+}