summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.3.ebuild')
-rw-r--r--dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.3.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.3.ebuild b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.3.ebuild
deleted file mode 100644
index 2177b9530f2d..000000000000
--- a/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.3.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit cmake-multilib
-
-MY_P="deviceatlas-enterprise-c-${PV/_p/_}"
-
-DESCRIPTION="API to detect devices based on the User-Agent HTTP header"
-HOMEPAGE="https://deviceatlas.com"
-SRC_URI="${MY_P}.tgz"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="doc examples"
-
-RDEPEND="dev-libs/libpcre[${MULTILIB_USEDEP}]"
-DEPEND="
- ${RDEPEND}"
-
-RESTRICT="fetch mirror bindist"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${PV}-src-cmakelists.patch"
-)
-
-pkg_nofetch() {
- eerror "Please go to https://deviceatlas.com/deviceatlas-haproxy-module"
- eerror "And download DeviceAtlas C API"
- eerror "Save the file as ${MY_P}.tgz in your DISTDIR directory."
-}
-
-multilib_src_install_all() {
- if use doc; then
- local -a HTML_DOCS=( Documentation )
- fi
-
- if use examples; then
- docinto examples
- dodoc Examples/daexutil.h
- dodoc Examples/example{0,1,2,3,4}.c
- dodoc Examples/util.c
- dodoc Examples/EXAMPLES.USAGE
- fi
-
- einstalldocs
-}