summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/gumbo')
-rw-r--r--dev-libs/gumbo/Manifest4
-rw-r--r--dev-libs/gumbo/gumbo-0.10.1.ebuild45
-rw-r--r--dev-libs/gumbo/gumbo-0.9.2.ebuild45
-rw-r--r--dev-libs/gumbo/gumbo-0.9.3.ebuild45
-rw-r--r--dev-libs/gumbo/gumbo-0.9.4.ebuild45
-rw-r--r--dev-libs/gumbo/metadata.xml10
6 files changed, 194 insertions, 0 deletions
diff --git a/dev-libs/gumbo/Manifest b/dev-libs/gumbo/Manifest
new file mode 100644
index 000000000000..4371112f82fe
--- /dev/null
+++ b/dev-libs/gumbo/Manifest
@@ -0,0 +1,4 @@
+DIST gumbo-0.10.1.tar.gz 2119285 SHA256 28463053d44a5dfbc4b77bcf49c8cee119338ffa636cc17fc3378421d714efad SHA512 bb1fb55cd07076ab6a9f38dc14db50397dbdca9a04ace4895dfba8b8cbc09038a96e26070c09c75fa929ada2e815affe233c1e2ecd8afe2aba6201647cf277d1 WHIRLPOOL 65e604194bf21373b5deada4fb32df7a64e6b78568955cd193e1399e6f74c0463290c1c6ea9a39f2df5b20713969f6651353a641bf9b98e0d2ab2d24f51a6911
+DIST gumbo-0.9.2.tar.gz 2087953 SHA256 82e5cd81e26a3eaac308ba9111573ecce2b48b550c673a6ec09853c12b05a381 SHA512 b04d95f43358afb4b5cf06749f6f325e00f52f6d87fba3a992f92a1c2bcb1e4ded7629379e905ed3e3c42c5685eecca78e44c4fd416e3336420b684b49637303 WHIRLPOOL ef20a3db2125c7dd5869a37241483a95f1de7dccce582f1f7b98cb79501354ece8535ebb4a687b0d668ad584e9b751b15450a5efb7ee39ecf865f20db6e7f33c
+DIST gumbo-0.9.3.tar.gz 2091579 SHA256 038354c0394591b270eafc9203aef4516afbf78a66fcb2c4fff5180593b003f0 SHA512 6acb368e7eb1a27a0f787e53432ae5aef78b3e8be8baa01e991603f6c76a7cca1f1455104deefe50a7c987e1037f6a6f4a224db027d36388eb4146e0fea01fa4 WHIRLPOOL b14d3aa47d6ab9623e98348d6ff3940c8083c5ec440e97e5f8ff5230cb262f5bcae7a0d5cbf42c8fce528467e144e58071a67187e34dd48577c9e2d693fcba6c
+DIST gumbo-0.9.4.tar.gz 2091855 SHA256 01643d1dce8e9465e345433b3328fdcac42760d141a448bb7d5a6e61425cd896 SHA512 87136ef6ee55f7827f343743b59b5148f589c69ee336ce0d7ad2d1ab57c6a383a1905e9e7d4243ba85d3120095bb979334bb9bcaaf8b57282abff344daa55024 WHIRLPOOL d647a3ab542c1d67e9b44656c5c94dfb4bc0c9f082074142ae0984f411cd50259e2664a8611329887bf23e83ed41227fa3efe0c0c3cebac4836c0691aa24d5d6
diff --git a/dev-libs/gumbo/gumbo-0.10.1.ebuild b/dev-libs/gumbo/gumbo-0.10.1.ebuild
new file mode 100644
index 000000000000..6a04d94d9bfc
--- /dev/null
+++ b/dev-libs/gumbo/gumbo-0.10.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="An implementation of the HTML5 parsing algorithm implemented as a pure C99 library"
+HOMEPAGE="https://github.com/google/gumbo-parser#readme"
+SRC_URI="https://github.com/google/gumbo-parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="doc test"
+
+S="${WORKDIR}/gumbo-parser-${PV}"
+
+DEPEND="test? ( dev-cpp/gtest )
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ dohtml -r docs/html/.
+ for page in docs/man/man3/* ; do
+ doman ${page}
+ done
+ fi
+}
diff --git a/dev-libs/gumbo/gumbo-0.9.2.ebuild b/dev-libs/gumbo/gumbo-0.9.2.ebuild
new file mode 100644
index 000000000000..35f534b6ee21
--- /dev/null
+++ b/dev-libs/gumbo/gumbo-0.9.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="An implementation of the HTML5 parsing algorithm implemented as a pure C99 library"
+HOMEPAGE="https://github.com/google/gumbo-parser#readme"
+SRC_URI="https://github.com/google/gumbo-parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="doc test"
+
+S="${WORKDIR}/gumbo-parser-${PV}"
+
+DEPEND="test? ( dev-cpp/gtest )
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ dohtml -r docs/html/.
+ for page in docs/man/man3/* ; do
+ doman ${page}
+ done
+ fi
+}
diff --git a/dev-libs/gumbo/gumbo-0.9.3.ebuild b/dev-libs/gumbo/gumbo-0.9.3.ebuild
new file mode 100644
index 000000000000..7194838edd21
--- /dev/null
+++ b/dev-libs/gumbo/gumbo-0.9.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="An implementation of the HTML5 parsing algorithm implemented as a pure C99 library"
+HOMEPAGE="https://github.com/google/gumbo-parser#readme"
+SRC_URI="https://github.com/google/gumbo-parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="doc test"
+
+S="${WORKDIR}/gumbo-parser-${PV}"
+
+DEPEND="test? ( dev-cpp/gtest )
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ dohtml -r docs/html/.
+ for page in docs/man/man3/* ; do
+ doman ${page}
+ done
+ fi
+}
diff --git a/dev-libs/gumbo/gumbo-0.9.4.ebuild b/dev-libs/gumbo/gumbo-0.9.4.ebuild
new file mode 100644
index 000000000000..7194838edd21
--- /dev/null
+++ b/dev-libs/gumbo/gumbo-0.9.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="An implementation of the HTML5 parsing algorithm implemented as a pure C99 library"
+HOMEPAGE="https://github.com/google/gumbo-parser#readme"
+SRC_URI="https://github.com/google/gumbo-parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="doc test"
+
+S="${WORKDIR}/gumbo-parser-${PV}"
+
+DEPEND="test? ( dev-cpp/gtest )
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ dohtml -r docs/html/.
+ for page in docs/man/man3/* ; do
+ doman ${page}
+ done
+ fi
+}
diff --git a/dev-libs/gumbo/metadata.xml b/dev-libs/gumbo/metadata.xml
new file mode 100644
index 000000000000..e86742b6679a
--- /dev/null
+++ b/dev-libs/gumbo/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>graaff@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/gumbo-parser#readme</remote-id>
+ </upstream>
+</pkgmetadata>