summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild')
-rw-r--r--dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
index f884a5d7fb2b..2294addb77a2 100644
--- a/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
+++ b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit ltprune xdg-utils
+inherit autotools
MY_P="${P/_pre/.}"
MY_PV="${PV/_pre/.}"
@@ -27,15 +27,20 @@ RDEPEND="dev-libs/glib:2
eekboard? ( dev-libs/eekboard )
introspection? ( dev-libs/gobject-introspection )
xtest? ( x11-libs/libXtst )"
-DEPEND="${RDEPEND}
- dev-util/intltool
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-Wreturn-type.patch
+ "${FILESDIR}"/${PN}-man.patch
+)
+
src_prepare() {
default
- xdg_environment_reset
+ eautoreconf
}
src_configure() {
@@ -48,5 +53,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+ use static-libs || find "${ED}" -name '*.la' -delete || die
}