summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/kqoauth/kqoauth-0.98.ebuild')
-rw-r--r--dev-libs/kqoauth/kqoauth-0.98.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/kqoauth/kqoauth-0.98.ebuild b/dev-libs/kqoauth/kqoauth-0.98.ebuild
new file mode 100644
index 000000000000..ba411804d98f
--- /dev/null
+++ b/dev-libs/kqoauth/kqoauth-0.98.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2 vcs-snapshot
+
+DESCRIPTION="Library for Qt that implements the OAuth 1.0 authentication specification"
+HOMEPAGE="https://github.com/kypeli/kQOAuth"
+SRC_URI="https://github.com/kypeli/kQOAuth/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # prevent tests from beeing built at src_compile
+ sed -i -e '/SUBDIRS/s/ tests//' ${PN}.pro || die "sed on ${PN}.pro failed"
+
+ qt4-r2_src_prepare
+}