summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libarcus/libarcus-3.4.1.ebuild')
-rw-r--r--dev-libs/libarcus/libarcus-3.4.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-libs/libarcus/libarcus-3.4.1.ebuild b/dev-libs/libarcus/libarcus-3.4.1.ebuild
deleted file mode 100644
index 120cd3820013..000000000000
--- a/dev-libs/libarcus/libarcus-3.4.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit cmake-utils python-single-r1
-
-MY_PN="libArcus"
-
-DESCRIPTION="This library facilitates communication between Cura and its backend"
-HOMEPAGE="https://github.com/Ultimaker/libArcus"
-SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0/3"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="${PYTHON_DEPS}
- dev-libs/protobuf
- $(python_gen_cond_dep '
- dev-python/sip[${PYTHON_MULTI_USEDEP}]
- python? ( dev-python/protobuf-python[${PYTHON_MULTI_USEDEP}] )
- ')"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_PYTHON=$(usex python ON OFF)
- -DBUILD_EXAMPLES=$(usex examples ON OFF)
- -DBUILD_STATIC=$(usex static-libs ON OFF)
- )
- use python && mycmakeargs+=( -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
- cmake-utils_src_configure
-}