summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libdnsres')
-rw-r--r--dev-libs/libdnsres/Manifest1
-rw-r--r--dev-libs/libdnsres/files/libdnsres-0.1a-autotools.patch28
-rw-r--r--dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild26
-rw-r--r--dev-libs/libdnsres/metadata.xml14
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/libdnsres/Manifest b/dev-libs/libdnsres/Manifest
new file mode 100644
index 000000000000..4629167b001f
--- /dev/null
+++ b/dev-libs/libdnsres/Manifest
@@ -0,0 +1 @@
+DIST libdnsres-0.1a.tar.gz 360583 SHA256 c0b94f27cb537eed42bc32ca9771f0955f717c66d34d1361e0a75600c6589307 SHA512 d6b1c248a99eeaea3524ee8af01dd31ba507179a69ffb313a167611792084d5efc99fe6462a63480932faa3493b01c3c43fc7575dab6aaade885583bee006f67 WHIRLPOOL 8ed056ef0691e3be8f7ff1aa0e8214b7eab96d0541c26d8f124a687a38d0f8cd4efa7de992c5dd2205e766af759b3b25b14bce7b2fb3884475b8b6492e52d443
diff --git a/dev-libs/libdnsres/files/libdnsres-0.1a-autotools.patch b/dev-libs/libdnsres/files/libdnsres-0.1a-autotools.patch
new file mode 100644
index 000000000000..3e2466af57f7
--- /dev/null
+++ b/dev-libs/libdnsres/files/libdnsres-0.1a-autotools.patch
@@ -0,0 +1,28 @@
+Index: libdnsres-0.1a/Makefile.am
+===================================================================
+--- libdnsres-0.1a.orig/Makefile.am
++++ libdnsres-0.1a/Makefile.am
+@@ -10,12 +10,12 @@ libdnsres_la_SOURCES = res_comp.c res_de
+ res_data.c res_init.c res_query.c res_send.c resolv.h dnsres.h \
+ gethostnamadr.c getaddrinfo.c getservbyname.c getservent.c base64.c \
+ dnsres-internal.h
+-libdnsres_la_LIBADD = @LIBOBJS@
++libdnsres_la_LIBADD = @LTLIBOBJS@
+ libdnsres_la_LDFLAGS = -version-info 0:1:0
+
+ include_HEADERS = dnsres.h
+
+-CFLAGS = -Wall -O0 -g -DRESOLVSORT
++AM_CFLAGS = -Wall -g -DRESOLVSORT
+ INCLUDES = -I$(top_srcdir)/compat @EVENTINC@
+
+ man_MANS = dnsres.3
+@@ -23,7 +23,7 @@ man_MANS = dnsres.3
+ noinst_PROGRAMS = simple_test
+ simple_test_SOURCES = test/simple_test.c
+ simple_test_INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/compat @EVENTINC@
+-simple_test_LDADD = -L$(top_buildir) -ldnsres @EVENTLIB@
++simple_test_LDADD = libdnsres.la @EVENTLIB@
+
+ verify: libdnsres.a
+ cd $(srcdir)/test && make verify
diff --git a/dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild b/dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild
new file mode 100644
index 000000000000..36d49c0411ca
--- /dev/null
+++ b/dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A non-blocking DNS resolver library"
+HOMEPAGE="http://www.monkey.org/~provos/libdnsres/"
+SRC_URI="http://www.monkey.org/~provos/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+
+DEPEND="dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-autotools.patch"
+ sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ eautoreconf
+}
diff --git a/dev-libs/libdnsres/metadata.xml b/dev-libs/libdnsres/metadata.xml
new file mode 100644
index 000000000000..ea027e94d2a5
--- /dev/null
+++ b/dev-libs/libdnsres/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+ <longdescription lang="en">
+ Libdnsres provides a non-blocking thread-safe API for resolving DNS names.
+ It requires that your main application is built on top of libevent.
+ Libdnsres' API essentially mirrors the traditional gethostbyname and
+ getaddrinfo interfaces. All return values have been replaced by callbacks
+ instead. The code borrows heavily from the BSD resolver library. In fact, it
+ is an extremely ugly hack to make the BSD resolver library non-blocking and
+ thread-safe without changing the API too much.
+ </longdescription>
+</pkgmetadata>